Colon character escaped on long url with port number

VERIFIED INVALID

Status

SeaMonkey
Location Bar
VERIFIED INVALID
16 years ago
10 years ago

People

(Reporter: Jeff Mandel, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Colon near end of url gets escaped with long urls.
https://host1.probes.com:443/http://host2.probes.com:2000
becomes
https://host1.probes.com:443/http://host2.probes.com%3A2000/
and server fails to find the url.

With trailing slash:
https://host1.probes.com:443/http://host2.probes.com:2000/
It works fine.

Works fine with explorer, does explorer just add the trailing slash?

Related to 121655?
I think the problem is that the ":" _is_ allowed to be escaped in URIs (and may
_need_ to be escaped, but I'm not sure)....
It doesn't _need_ to be, but it can be, and a server MUST consider the two forms
to be identical, per RFC2618 (since the second host is technically considered as
part of the path in the url)

We do, because the escape/unescape api doesn't want to have to go and parse the
url, esp when its entered from the urlbar and we may be doing fixup anyway.

This is INVALID or evangalism.

Comment 3

16 years ago
We escape : in the filenamepart of an url, we do not in the directory part. We
do this because in a relative url (in theory masked by filename-mask) a colon
would mark a scheme and make it an absolute url, which is definitly not what we
want. 

Anyway, Bradley is right, the server should be able to handle both versions.

Comment 4

16 years ago
*** Bug 167707 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
http://www.w3.org/Addressing/rfc1738.txt

   Many URL schemes reserve certain characters for a special meaning:
   their appearance in the scheme-specific part of the URL has a
   designated semantics. If the character corresponding to an octet is
   reserved in a scheme, the octet must be encoded.  The characters ";",
   "/", "?", ":", "@", "=" and "&" are the characters which may be
   reserved for special meaning within a scheme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
OS: Mac System 9.x → All
Resolution: --- → INVALID

Comment 6

14 years ago
V/invalid.
Status: RESOLVED → VERIFIED
QA Contact: claudius → benc
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.