Closed Bug 1554178 Opened 4 months ago Closed 4 months ago

Perma test_remote_settings_poll.js and test_remote_settings.js failures when Gecko 68 merges to release on 2019-07-01

Categories

(Firefox :: Remote Settings Client, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 + fixed
firefox69 --- fixed

People

(Reporter: aryx, Assigned: leplatrem)

Details

(Keywords: regression)

Attachments

(1 file)

This only affect shippable opt builds (= how the release builds will be):

beta-as-release simulation: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=7f25bf6ea553b7dca734a80947fbfe8f0053f265&selectedJob=247804087

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=247804087&repo=try

19:10:46 INFO - TEST-PASS | services/settings/test/unit/test_remote_settings_poll.js | test_client_last_check_is_saved - [test_client_last_check_is_saved : 300] 1558552246 != 0
19:10:46 INFO - (xpcshell/head.js) | test run_next_test 12 pending (2)
19:10:46 INFO - (xpcshell/head.js) | test test_client_last_check_is_saved finished (2)
19:10:46 INFO - services/settings/test/unit/test_remote_settings_poll.js | Starting clear_state
19:10:46 INFO - (xpcshell/head.js) | test clear_state pending (2)
19:10:46 INFO - (xpcshell/head.js) | test run_next_test 12 finished (2)
19:10:46 INFO - (xpcshell/head.js) | test run_next_test 13 pending (2)
19:10:46 INFO - (xpcshell/head.js) | test clear_state finished (2)
19:10:46 INFO - services/settings/test/unit/test_remote_settings_poll.js | Starting test_age_of_data_is_reported_in_uptake_status
19:10:46 INFO - (xpcshell/head.js) | test test_age_of_data_is_reported_in_uptake_status pending (2)
19:10:46 INFO - (xpcshell/head.js) | test run_next_test 13 finished (2)
19:10:46 WARNING - TEST-UNEXPECTED-FAIL | services/settings/test/unit/test_remote_settings_poll.js | test_age_of_data_is_reported_in_uptake_status - [test_age_of_data_is_reported_in_uptake_status : 118] parent must be in snapshot. Has []. - false == true
19:10:46 INFO - resource://testing-common/TelemetryTestUtils.jsm:assertEvents:118
19:10:46 INFO - /Users/cltbld/tasks/task_1558551879/build/tests/xpcshell/tests/services/settings/test/unit/test_remote_settings_poll.js:test_age_of_data_is_reported_in_uptake_status:317
19:10:46 INFO - /Users/cltbld/tasks/task_1558551879/build/tests/xpcshell/head.js:_do_main:227
19:10:46 INFO - /Users/cltbld/tasks/task_1558551879/build/tests/xpcshell/head.js:_execute_test:529
19:10:46 INFO - -e:null:1
19:10:46 INFO - exiting test
19:10:46 INFO - Unexpected exception NS_ERROR_ABORT:
19:10:46 INFO - _abort_failed_test@/Users/cltbld/tasks/task_1558551879/build/tests/xpcshell/head.js:742:20
19:10:46 INFO - do_report_result@/Users/cltbld/tasks/task_1558551879/build/tests/xpcshell/head.js:849:5
19:10:46 INFO - Assert<@/Users/cltbld/tasks/task_1558551879/build/tests/xpcshell/head.js:57:5
19:10:46 INFO - proto.report@resource://testing-common/Assert.jsm:213:10
19:10:46 INFO - proto.ok@resource://testing-common/Assert.jsm:233:10
19:10:46 INFO - assertEvents@resource://testing-common/TelemetryTestUtils.jsm:118:12
19:10:46 INFO - test_age_of_data_is_reported_in_uptake_status@/Users/cltbld/tasks/task_1558551879/build/tests/xpcshell/tests/services/settings/test/unit/test_remote_settings_poll.js:317:22
19:10:46 INFO - _do_main@/Users/cltbld/tasks/task_1558551879/build/tests/xpcshell/head.js:227:6
19:10:46 INFO - _execute_test@/Users/cltbld/tasks/task_1558551879/build/tests/xpcshell/head.js:529:5
19:10:46 INFO - @-e:1:1
19:10:46 INFO - exiting test
19:10:46 INFO - <<<<<<<

Flags: needinfo?(mathieu)

This seems to be the same as https://bugzilla.mozilla.org/show_bug.cgi?id=1551347

I'll have a look...

Assignee: nobody → mathieu
Flags: needinfo?(mathieu)
Pushed by mleplatre@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/204c7f42d427
Disable events sampling for uptake telemetry tests r=glasserc
Pushed by mleplatre@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a02e5b470793
Disable events sampling for uptake telemetry tests r=glasserc
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Flags: needinfo?(mathieu)
Whiteboard: [checkin-needed-beta]
You need to log in before you can comment on or make changes to this bug.