Perma TEST-UNEXPECTED-FAIL | No test output (missing mozunit.main() call?): z:\task_1558700248\build\src\testing\mozbase\mozdebug\tests\test.py

RESOLVED FIXED in Firefox 69

Status

defect
P5
normal
RESOLVED FIXED
3 months ago
3 months ago

People

(Reporter: intermittent-bug-filer, Assigned: saschanaz)

Tracking

(Regression, {intermittent-failure, regression})

Version 3
mozilla69
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox67 unaffected, firefox68 unaffected, firefox69 fixed)

Details

Attachments

(1 attachment)

Filed by: nerli [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=248203394&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/YsLH5Jo9TsSCxJysGN-xfw/runs/0/artifacts/public/logs/live_backing.log


[task 2019-05-24T13:43:49.058Z] 0:38.08 ValueError: level must be >= 0
[task 2019-05-24T13:43:49.058Z] 0:38.08 TEST-UNEXPECTED-FAIL | No test output (missing mozunit.main() call?): z:\task_1558700248\build\src\testing\mozbase\mozdebug\tests\test.py
[task 2019-05-24T13:43:49.058Z] 0:38.08 Setting retcode to 1 from z:\task_1558700248\build\src\testing\mozbase\mozdebug\tests\test.py
[task 2019-05-24T13:43:49.076Z] 0:38.10 z:\task_1558700248\build\src\testing\mozbase\mozcrash\tests\test_java_exception.py
[task 2019-05-24T13:43:49.077Z] 0:38.10 Traceback (most recent call last):
[task 2019-05-24T13:43:49.078Z] 0:38.10 File "z:\task_1558700248\build\src\testing\mozbase\mozcrash\tests\test_java_exception.py", line 6, in <module>
[task 2019-05-24T13:43:49.079Z] 0:38.10 import mozunit
[task 2019-05-24T13:43:49.079Z] 0:38.10 File "z:\task_1558700248\build\src\build\mach_bootstrap.py", line 396, in call
[task 2019-05-24T13:43:49.079Z] 0:38.10 module = self.original_import(name, globals, locals, fromlist, level)
[task 2019-05-24T13:43:49.079Z] 0:38.10 File "z:\task_1558700248\build\src\config\mozunit\mozunit_init
.py", line 8, in <module>
[task 2019-05-24T13:43:49.079Z] 0:38.10 from .mozunit import *
[task 2019-05-24T13:43:49.079Z] 0:38.10 File "z:\task_1558700248\build\src\build\mach_bootstrap.py", line 396, in call
[task 2019-05-24T13:43:49.079Z] 0:38.10 module = self._original_import(name, globals, locals, fromlist, level)
[task 2019-05-24T13:43:49.080Z] 0:38.10 File "z:\task_1558700248\build\src\config\mozunit\mozunit\mozunit.py", line 12, in <module>
[task 2019-05-24T13:43:49.080Z] 0:38.10 import pytest
[task 2019-05-24T13:43:49.080Z] 0:38.10 File "z:\task_1558700248\build\src\build\mach_bootstrap.py", line 396, in call
[task 2019-05-24T13:43:49.080Z] 0:38.10 module = self._original_import(name, globals, locals, fromlist, level)
[task 2019-05-24T13:43:49.080Z] 0:38.10 File "z:\task_1558700248\build\src\third_party\python\pytest\src\pytest.py", line 9, in <module>
[task 2019-05-24T13:43:49.080Z] 0:38.10 from _pytest.config import main, UsageError, cmdline, hookspec, hookimpl
[task 2019-05-24T13:43:49.080Z] 0:38.10 File "z:\task_1558700248\build\src\build\mach_bootstrap.py", line 396, in call
[task 2019-05-24T13:43:49.081Z] 0:38.10 module = self.original_import(name, globals, locals, fromlist, level)
[task 2019-05-24T13:43:49.083Z] 0:38.10 File "z:\task_1558700248\build\src\third_party\python\pytest\src_pytest\config_init
.py", line 9, in <module>
[task 2019-05-24T13:43:49.084Z] 0:38.10 import six
[task 2019-05-24T13:43:49.085Z] 0:38.11 File "z:\task_1558700248\build\src\build\mach_bootstrap.py", line 396, in call
[task 2019-05-24T13:43:49.086Z] 0:38.11 module = self.original_import(name, globals, locals, fromlist, level)
[task 2019-05-24T13:43:49.087Z] 0:38.11 File "z:\task_1558700248\build\src\third_party\python\six\six.py", line 679, in <module>
[task 2019-05-24T13:43:49.088Z] 0:38.11 exec
= getattr(moves.builtins, "exec")
[task 2019-05-24T13:43:49.089Z] 0:38.11 File "z:\task_1558700248\build\src\third_party\python\six\six.py", line 92, in get
[task 2019-05-24T13:43:49.090Z] 0:38.11 result = self._resolve()
[task 2019-05-24T13:43:49.091Z] 0:38.11 File "z:\task_1558700248\build\src\third_party\python\six\six.py", line 115, in _resolve
[task 2019-05-24T13:43:49.091Z] 0:38.11 return _import_module(self.mod)
[task 2019-05-24T13:43:49.092Z] 0:38.11 File "z:\task_1558700248\build\src\third_party\python\six\six.py", line 82, in _import_module
[task 2019-05-24T13:43:49.093Z] 0:38.11 import(name)
[task 2019-05-24T13:43:49.094Z] 0:38.12 File "z:\task_1558700248\build\src\build\mach_bootstrap.py", line 396, in call
[task 2019-05-24T13:43:49.096Z] 0:38.12 module = self._original_import(name, globals, locals, fromlist, level)
[task 2019-05-24T13:43:49.097Z] 0:38.12 ValueError: level must be >= 0
[task 2019-05-24T13:43:49.097Z] 0:38.12 TEST-UNEXPECTED-FAIL | No test output (missing mozunit.main() call?): z:\task_1558700248\build\src\testing\mozbase\mozcrash\tests\test_java_exception.py
[task 2019-05-24T13:43:49.099Z] 0:38.12 z:\task_1558700248\build\src\testing\mozbase\mozcrash\tests\test_basic.py
[task 2019-05-24T13:43:49.100Z] 0:38.12 Traceback (most recent call last):
[task 2019-05-24T13:43:49.101Z] 0:38.12 File "z:\task_1558700248\build\src\testing\mozbase\mozcrash\tests\test_basic.py", line 6, in <module>
[task 2019-05-24T13:43:49.101Z] 0:38.12 import mozunit

Flags: needinfo?(james)
Regressed by: 1552914

I think this is caused by Bug 1550956 since backing that out locally seemed to cure the problem.

Flags: needinfo?(saschanaz)
Flags: needinfo?(cmanchester)
Flags: needinfo?(james)

It seems tests that previously couldn't run on Py3 are now explicitly failing.

Flags: needinfo?(saschanaz)
Flags: needinfo?(saschanaz)

Negative value for import level is obsolete in Python 3, which was used on Py2 for implicit relative import. This change ensures the level value to be >=0 on Py3 to fix test failures.

Regressed by: 1550956
No longer regressed by: 1552914
Summary: Intermittent 0:38.08 TEST-UNEXPECTED-FAIL | No test output (missing mozunit.main() call?): z:\task_1558700248\build\src\testing\mozbase\mozdebug\tests\test.py → Perma TEST-UNEXPECTED-FAIL | No test output (missing mozunit.main() call?): z:\task_1558700248\build\src\testing\mozbase\mozdebug\tests\test.py

Cannot add checkin-needed from here, could you add it? Thanks!

Flags: needinfo?(saschanaz) → needinfo?(mh+mozilla)
Flags: needinfo?(mh+mozilla)
Keywords: checkin-needed

Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/f29667d1037a
Fix Python 3 negative import level error r=glandium

Keywords: checkin-needed
Duplicate of this bug: 1555254
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Flags: needinfo?(cmanchester)
Assignee: nobody → saschanaz
You need to log in before you can comment on or make changes to this bug.