Closed Bug 1554286 Opened 5 months ago Closed 4 months ago

Update Mac to Rust beta 1.36

Categories

(Firefox Build System :: General, task)

All
macOS
task
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1563378
mozilla69

People

(Reporter: erahm, Assigned: froydnj)

References

(Blocks 1 open bug)

Details

Attachments

(3 obsolete files)

Similar to bug 1533010, we need to update mac to the latest rust beta in order to enable cross-language LTO.

Latest try looks happy: https://treeherder.mozilla.org/#/jobs?repo=try&revision=72b38ab246852b449b02456b207e6b04510ed003

Nathan, would you mind landing this if/when you r+ it? If it needs more work would you mind taking it over?

Flags: needinfo?(nfroyd)
Attachment #9067488 - Attachment is obsolete: true
Attachment #9067420 - Attachment is obsolete: true

We would like to switch to using cross-language LTO on all of our
platforms, and we need to use a beta version of Rust on Mac to do that.

Pushed by nfroyd@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/16872c13ee93
move Mac builds to Rust 1.36-beta; r=chmanchester
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Assignee: nobody → nfroyd
Flags: needinfo?(nfroyd)

Nathan, can you confirm whether this needs to be backed out before the merge?

Flags: needinfo?(nfroyd)

Backed out changeset 16872c13ee93 (Bug 1554286) per developer's request CLOSED TREE

The sheriffs were kind enough to back this out for me.

Status: RESOLVED → REOPENED
Flags: needinfo?(nfroyd)
OS: Unspecified → macOS
Hardware: Unspecified → All
Resolution: FIXED → ---
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fbac4c103918
Backed out changeset 16872c13ee93 per developer's request CLOSED TREE

The normal 1.36 update obsoletes this.

Status: REOPENED → RESOLVED
Closed: 5 months ago4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1563378
Attachment #9069027 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.