Closed Bug 1554317 Opened 5 months ago Closed 5 months ago

Land string for recommendation icon title in beta

Categories

(Toolkit :: Add-ons Manager, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox68 + verified
firefox69 --- verified

People

(Reporter: mstriemer, Assigned: mstriemer)

References

Details

Attachments

(1 file)

When you hover the recommended icon you should see a "Recommended" tooltip.

Mocks: https://mozilla.invisionapp.com/share/XBGB8FSG49S#/screens/357095757

This string will be used as the alt and title text for the recommended icon
in about:addons. The patch to add the image will follow, once we have a way
of identifying add-ons that were recommended.

Blocks: 1539699
No longer blocks: 1540253
Assignee: nobody → mstriemer
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a58efeaf9c94
String for showing add-on recommendations r=rpl,flod
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Comment on attachment 9067462 [details]
Bug 1554317 - String for showing add-on recommendations r?flod!,rpl!

Beta/Release Uplift Approval Request

  • User impact if declined: Users could have untranslated text when recommendations are shown in HTML about:addons.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This just lands the strings that will be used in a future patch, which is to be uplifted.
  • String changes made/needed:
Attachment #9067462 - Flags: approval-mozilla-beta?

Comment on attachment 9067462 [details]
Bug 1554317 - String for showing add-on recommendations r?flod!,rpl!

land a string for about:addons ahead of upcoming patch

flod can you confirm this is ok to land in beta?

Flags: needinfo?(francesco.lodolo)
Attachment #9067462 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

(In reply to Julien Cristau [:jcristau] from comment #5)

flod can you confirm this is ok to land in beta?

Not exactly happy, but I won't block on it.

I'd like to have a better understanding of what the plan is for about:addons on 68, given the dependencies of bug 1533795, and the amount of things that landed during the soft freeze.

Flags: needinfo?(francesco.lodolo)

(In reply to Francesco Lodolo [:flod] from comment #6)

I'd like to have a better understanding of what the plan is for about:addons on 68, given the dependencies of
bug 1533795, and the amount of things that landed during the soft freeze.

The major effort here is (and has been) converting about:addons from XUL to HTML. This has been in process since 66. The consternation is about when we should have enabled this by default (to which the answer is probably before beta merge, but we did not); preffing it on should happen when it's "good enough" -- but the line we've been walking is whether to enable with things that are not yet there (and subject QA to that delay) or leave it pref'd off until those pieces are in place (those are the uplifts). Most of those things are either small or a subset of other things that landed (like recommendations in list view), but the reality is that this is the intersection of the new release process, an ESR, and the HTML conversion.

This one, however, is for getting a string in as early as possible (now) for patches that will land later (this week or next) around showing which extensions are recommended in the client. That was not going to land prior to beta in order to wait for the autograph pieces to enforce our signing process, which either landed late last week or will land this week.

It's admittedly not been the smoothest process, but it's the best we've been able to do with the staffing and demands we have for 68.

Depends on: 1559895

This issue is Verified as Fixed on Firefox 69.0a1 (20190617214029) under Windows 10 Pro 64-bit and MacOS High Sierra 10.13.6.

To verify the validity of the fix, the following prefs have been modified as follows:

Furthermore, for test purposes, several add-ons from dev have been marked with the recommended tag and pushed to the list of recommended addons displayed on about:addons.

When the above conditions are met, the ‘Recommended’ badge and the ‘Recommended’ string upon hovering over the badge are displayed.

However, while validating the fix, one potential issue has been encountered. We observed that the badge and string for recommended themes which are installed, are not displayed. For further details, please refer to: https://bugzilla.mozilla.org/show_bug.cgi?id=1559895.

Status: RESOLVED → VERIFIED

Verified the fix using Beta 68.0b14/20190627143605 under Windows 10 Pro 64-bit and macOS High Sierra 10.13.6.

The ‘Recommended’ badge and the ‘Recommended’ string upon hovering over the badge are displayed.

You need to log in before you can comment on or make changes to this bug.