Crash viewing XML local file via stylesheet

RESOLVED WORKSFORME

Status

()

Core
XSLT
--
critical
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Jordi Albornoz, Assigned: peterv)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
The instruction at 0x017b492c referenced memory at 0x00000000.
A very reproduceable crash.  I don't have the debug symbols but the
stack trace that I got was as follows:
GKCONTENT! 017b492c()
XPCOM! 610e86f7()
TRANSFORMIIX! 60adb09f()
TRANSFORMIIX! 60adaf37()
GKCONTENT! 017b933b()
GKCONTENT! 017b94b2()
GKPARSER! 604d4a2a()
GKPARSER! 604e34ac()
NECKO! 6098a59f()
NECKO! 6095bde9()
XPCOM! 6111453e()
SETUPAPI! 778b0c24()

I was able to reproduce it reliably using the following procedure:
1. File->Open File...
2. Open the attached XML file that uses the also attached XSL stylesheet for 
rendering.
3. Hit refresh quickly a couple of times in a row.
4. Mozilla crashes.

Mozilla version is as follows:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530

BuildID: 20020503012
(Reporter)

Comment 1

16 years ago
Created attachment 89961 [details]
The XML file that I use to reproduce the crash.
(Reporter)

Comment 2

16 years ago
Created attachment 89962 [details]
One of the XSL stylesheets required
(Reporter)

Comment 3

16 years ago
Created attachment 89963 [details]
Corrected XML file that I use to reprocude the crash

I simply changed the reference to the stylesheet to be a relative path.
Attachment #89961 - Attachment is obsolete: true
(Reporter)

Comment 4

16 years ago
Created attachment 89964 [details]
Another XSL file that is required.
(Reporter)

Comment 5

16 years ago
Created attachment 89965 [details]
Last of the XSL stylesheets used.
Do you have a talkback ID ?

This doesn't crash for me on win2k with 20020630 or 1.0 but it's possible that i
use the wrong files.
Can you please attach one .zip file with the needed files ?

(Reporter)

Comment 7

16 years ago
Created attachment 89981 [details]
Zip file with the appropriate files to reproduce crash.

Also, take a look at talkback ID: TB7937926Z
nsXMLContentSink::Observe
[d:\builds\seamonkey\mozilla\content\xml\document\src\nsXMLContentSink.cpp, line
419]
nsObserverService::NotifyObservers
[d:\builds\seamonkey\mozilla\xpcom\ds\nsObserverService.cpp, line 213]
XSLTProcessor::SignalTransformEnd
[d:\builds\seamonkey\mozilla\extensions\transformiix\source\xslt\XSLTProcessor.cpp,
line 2529]
XSLTProcessor::TransformDocument
[d:\builds\seamonkey\mozilla\extensions\transformiix\source\xslt\XSLTProcessor.cpp,
line 2474]
nsTransformMediator::TryToTransform
[d:\builds\seamonkey\mozilla\content\xsl\document\src\nsTransformMediator.cpp,
line 113]
nsTransformMediator::SetStyleSheetContentModel
[d:\builds\seamonkey\mozilla\content\xsl\document\src\nsTransformMediator.cpp,
line 162]
nsXSLContentSink::DidBuildModel
[d:\builds\seamonkey\mozilla\content\xsl\document\src\nsXSLContentSink.cpp, line
147]
nsExpatDriver::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsExpatDriver.cpp, line 938]
nsParser::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1253]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1790]
nsParser::OnStopRequest
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2419]
nsFileChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\file\src\nsFileChannel.cpp, line 522]
nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 213]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 597]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 530]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1078]
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 451]
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1473]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1809]
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1827]
WinMainCRTStartup()
KERNEL32.DLL + 0xd326 (0x77e8d326) 
-> XLST (looks like a dupe of bug 129006)
Assignee: Matti → peterv
Component: Browser-General → XSLT
Keywords: crash
QA Contact: imajes-qa → keith
Summary: Crash in GKCONTENT.DLL viewing XML local file via stylesheet → Crash viewing XML local file via stylesheet
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

16 years ago
WORKSFORME on trunk. BuildID looks like it has the fix for bug 129006.
Jordi, are you sure you didn't have a broken link or something?
If the attached testcase doesn't work for you, please test a current trunk.
If you can reproduce it there, please shrink your testcase.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

16 years ago
I just downloaded the latest nightly build (Build ID: 2002070304) and it no 
longer crashes for me.  I'm not convinced it's the same problem as bug 129006 
but whatever it was, it no longer seems to crash.
You need to log in before you can comment on or make changes to this bug.