Closed Bug 1554437 Opened 4 months ago Closed 4 months ago

Download-completed animation doesn't work

Categories

(Firefox :: Theme, defect, P1, minor)

69 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- unaffected
firefox69 --- verified

People

(Reporter: euthanasia_waltz, Assigned: aswan)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR:
Download something.
AR:
No animation when downloading finished. Buttons's color is still gray/black.
ER:
Animated and the color is blue.

mozregression:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f287bb6c18942c75aca41d54987006951270628d&tochange=c8e9b6a81194dff2d37b4f67d23a419fd4587e49

Regressed by: 1519577
Priority: -- → P1
QA Whiteboard: [qa-regression-triage]
Duplicate of this bug: 1554981

:aswan, are you able to take this?

Flags: needinfo?(sfoster)
Flags: needinfo?(sfoster) → needinfo?(aswan)

I'm pretty certain this was bug 1519577, no need to verify that.

Assignee: nobody → aswan
Flags: needinfo?(aswan)

These selectors were using the direct child combinator which broke
when toolbarbutton switched away from XBL.

Component: XUL Widgets → Theme
Product: Toolkit → Firefox
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bf0c87374807
Fix selectors on download-indicators-anchor r=sfoster,dao
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

I have reproduced this issue in Nightly v69.0a1 from 2019-05-25 and verified the fix in Nightly v69.0a1 from 2019-06-02 on Windows 10. Thank you.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-regression-triage]
You need to log in before you can comment on or make changes to this bug.