Closed Bug 1554602 Opened 1 year ago Closed 1 year ago

3.59 - 10.5% tsvg_static / tsvgr_opacity (linux64-shippable, linux64-shippable-qr, windows10-64-shippable, windows10-64-shippable-qr, windows7-32-shippable) regression on push 9c779a0d65aeaacc948bb8c29dcc3c7e70f521f4

Categories

(Core :: DOM: Content Processes, defect)

Desktop
All
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: igoldan, Unassigned, NeedInfo)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=dea007366ef2cacf6132b1ec5eb29c3827ddd5bf&tochange=9c779a0d65aeaacc948bb8c29dcc3c7e70f521f4

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

11% tsvgr_opacity windows7-32-shippable opt e10s stylo 106.73 -> 117.94
9% tsvgr_opacity windows7-32-shippable opt e10s stylo 109.58 -> 119.27
9% tsvgr_opacity linux64-shippable-qr opt e10s stylo 100.34 -> 109.21
9% tsvgr_opacity windows10-64-shippable opt e10s stylo 104.17 -> 113.20
8% tsvgr_opacity windows10-64-shippable-qr opt e10s stylo 97.50 -> 105.57
8% tsvgr_opacity linux64-shippable opt e10s stylo 142.38 -> 153.09
4% tsvg_static linux64-shippable-qr opt e10s stylo 45.32 -> 46.95

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=21088

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Performance_sheriffing/Talos/RegressionBugsHandling

Component: General → DOM: Content Processes
Product: Testing → Core
Flags: needinfo?(brennie)

I plan to address these issues. I took a look at the profiles but nothing jumps out at me as a likely cause for the regression. I have a theory that this patch may be the culprit, but due to bug 1554724, I can't run Talos jobs in Try to confirm whether or not reverting this patch (and relevant parts of this patch) solves the issue.

Depends on: 1554724

I think this is just the weirdness of how the the tsvg tests work again again. Slight timing changes in how we measure the page load cycle end up showing up here because the things that they test are so trivial, and we wind up measuring the wrong thing.

In actual fact, if anything, these changes should have slightly improved performance, since the new code is considerably cheaper than the old code.

:kmag, would you say that this bug should be closed as WONTFIX as it is not likely a real regression?

Flags: needinfo?(brennie) → needinfo?(kmaglione+bmo)

I think so, yes.

Flags: needinfo?(kmaglione+bmo)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX

(In reply to Kris Maglione [:kmag] from comment #3)

I think this is just the weirdness of how the the tsvg tests work again again. Slight timing changes in how we measure the page load cycle end up showing up here because the things that they test are so trivial, and we wind up measuring the wrong thing.

In actual fact, if anything, these changes should have slightly improved performance, since the new code is considerably cheaper than the old code.

Sounds like tsvgr_opacity requires maintenance. Could you please plan the required work for this?

Flags: needinfo?(kmaglione+bmo)
You need to log in before you can comment on or make changes to this bug.