Closed Bug 1554690 Opened 2 years ago Closed 2 years ago

restrict preferences branches which can be set/modified by some default files

Categories

(Core :: Preferences: Backend, task)

task
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1572336

People

(Reporter: aryx, Unassigned)

Details

In bug 1542244 the file testing/marionette/prefs/marionette.js got two new additions:

+// Turn off DOM Push
+pref("dom.push.connection.enabled", false);
+
+// Privacy and tracking protection
+pref("privacy.trackingprotection.enabled", false);

Despite the path, these preferences ship as part of the default Firefox preferences.

To prevent from accidentally shipping such changes, automatically forbidding them would be helpful, e.g. allow that file to only set marionette.* preferences.

Would be storing the whitelisted branches at the top of the file, reading them and checking no pref( call starts with anything else be the way to go (in a Makefile)?

I was just looking at marionette.js as part of bug 1572331.

There is no mechanism for restricting what prefs can be specified in a prefs file, and I don't think adding one would be a good idea.

I think the real problem here is that it's not obvious from the filename and path that these prefs ship with Firefox. Also there are two files called marionette.js, one of which is an actual JavaScript file, and the other is a prefs file. If we move the prefs into all.js it would make things less confusing.

I filed bug 1572336 to merge marionette.js into all.js.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1572336
You need to log in before you can comment on or make changes to this bug.