highlighting all screwed up

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: warrensomebody, Assigned: mjudge)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Do this:
- go to the mozilla page
- click and hold on some piece of text halfway down in the right-hand (white)
area
- drag down through the white area to select
- move left into the menu (black) area
- drag up through the black area
(notice that the selection goes from the bottom to the drag point -- seems
weird)

Now here's the tricky part:
- if you drag right back into the white area below the point you started and let
go, you'll have selected the text in the white area from the start point to the
end point, but...
- if you drag to the right back into the white area above the point where you
started and let go, you'll end up with all sorts of weird highlight artifacts

Double clicking on a line at this point will de-select most of the line, and
select the word that you double clicked on, but anything in a different font or
style will stay selected.

Updated

19 years ago
Assignee: troy → mjudge

Updated

19 years ago
Assignee: mjudge → kin
Component: Layout → Selection
OS: other → All
Hardware: Other → All

Comment 1

19 years ago
I see this on Mac (artifacts as you drag-scroll selection though not all of the
examples warren cites); reset to all platforms.  Reassign to kin@netscape.com;
reset component to selection

Updated

19 years ago
Assignee: kin → mjudge

Comment 2

19 years ago
Reassigning to mjudge@netscape.com, he has a fix for this in his source tree.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

19 years ago
this is fixed now
(Reporter)

Comment 4

19 years ago
Looks good. Thanks.

Updated

19 years ago
QA Contact: petersen → elig

Comment 5

19 years ago
QA Assigning to self; this is a Selection bug.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
I'm not sure if I understand exactly how to reproduce this bug. But, since Warren
says it's fine with him, I'm rubber-stamping as verified.

Corruption upon drag-scrolling (Linux/Mac OS only) is covered by 15384.
You need to log in before you can comment on or make changes to this bug.