Closed Bug 1554949 Opened 3 years ago Closed 3 years ago

Build fails with recent Linux kernel.

Categories

(Core :: Audio/Video, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr68 --- fixed
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

Details

Attachments

(1 file)

/home/emilio/src/moz/gecko/media/webrtc/trunk/webrtc/rtc_base/physicalsocketserver.cc:67:27: error: use of undeclared identifier 'SIOCGSTAMP'
10:38.18   int ret = ioctl(socket, SIOCGSTAMP, &tv_ioctl);
10:38.18    

See:

For the analysis.

Recent kernel commit1 moved a bit the define for this constant. This revealed
a missing include in WebRTC.

I filed this upstream in:

And sent a patch in:

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/49be991ad4d9
Fix WebRTC build failure with newer linux kernel. r=dminor
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Duplicate of this bug: 1567446

Comment on attachment 9067982 [details]
Bug 1554949 - Fix WebRTC build failure with newer linux kernel. r=dminor

Beta/Release Uplift Approval Request

  • User impact if declined: No user impact, but people may be unable to build 68 / ESR on newer Linux kernels.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Trivial build fix that allows to build FF68 on newer Linux kernels.
  • String changes made/needed: none
Attachment #9067982 - Flags: approval-mozilla-release?

Comment on attachment 9067982 [details]
Bug 1554949 - Fix WebRTC build failure with newer linux kernel. r=dminor

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: See above
  • User impact if declined: See above
  • Fix Landed on Version: 69
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Trivial build fix on Linux only.
  • String or UUID changes made by this patch: none
Attachment #9067982 - Flags: approval-mozilla-esr68?

Comment on attachment 9067982 [details]
Bug 1554949 - Fix WebRTC build failure with newer linux kernel. r=dminor

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: See above
  • User impact if declined: See above
  • Fix Landed on Version: 69
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Trivial build fix on Linux only.
  • String or UUID changes made by this patch: none

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: See above
  • User impact if declined: See above
  • Fix Landed on Version: 69
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Trivial build fix on Linux only.
  • String or UUID changes made by this patch: none
Attachment #9067982 - Flags: approval-mozilla-esr68?

Well, BMO got confused here...

Comment on attachment 9067982 [details]
Bug 1554949 - Fix WebRTC build failure with newer linux kernel. r=dminor

Fixes a build issue on newer Linux kernels. Approved for 68.1esr. Since it doesn't affect the builds we ship, I'll approve this for mozilla-release as well in the event that we ship another dot release from there, but I won't guarantee that'll happen either.

Attachment #9067982 - Flags: approval-mozilla-release?
Attachment #9067982 - Flags: approval-mozilla-release+
Attachment #9067982 - Flags: approval-mozilla-esr68?
Attachment #9067982 - Flags: approval-mozilla-esr68+

Also pushed to FIREFOX_ESR_68_0_X_RELBRANCH for consistency:
https://hg.mozilla.org/releases/mozilla-esr68/rev/03fe96d5969ac6885ca539bf7759780ed75a1375

No longer depends on: 1646904
You need to log in before you can comment on or make changes to this bug.