Closed Bug 1555231 Opened 5 months ago Closed 2 months ago

[Protections Panel] Replace footer with Show Report line button and "X blocked" label

Categories

(Firefox :: Site Identity, task, P1)

task

Tracking

()

RESOLVED FIXED
Firefox 70
Tracking Status
firefox69 --- wontfix
firefox70 --- fixed

People

(Reporter: nhnt11, Assigned: timhuang)

References

(Blocks 1 open bug)

Details

(Whiteboard: [skyline])

Attachments

(5 files)

No description provided.
Priority: -- → P1
Whiteboard: [protection-report] [skyline]

This also needs to update the design of the footer, see latest specs.

Summary: [Protections Panel] Implement "Trackers Blocked This Week" in footer section → [Protections Panel] Implement "Trackers Blocked This Week" in footer section and update styles
Whiteboard: [protection-report] [skyline] → [skyline]
Duplicate of this bug: 1567294

Also needs to add a tooltip, see bug 1567294

Assignee: nobody → tihuang
Status: NEW → ASSIGNED
Summary: [Protections Panel] Implement "Trackers Blocked This Week" in footer section and update styles → [Protections Panel] Replace footer with Show Report line button and "X blocked" label

This patch makes changes to the protection setting button and the footer
section. First, it moves the protection setting button into the footer
section. Second, it updates styles of footer section. And then, it
changes the hover state of buttons.

In addition, it adds a new function in gProtectionsHandler in order to
open the 'about:protections' page when clicking the 'Show report' button.

This patch adds two strings, one for the blocked tracker counter and
another for the tooltip.

Depends on D39692

This patch implements the tooltip for showing the earliest date of the
block tracker record. The tooltip will be set during the initiation
gProtectionHandler module.

Depends on D39693

This patch replace the fake tracker numbers with the real data from the
TrackingDBService.

Depends on D39694

Pushed by tihuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/35fe7ce18534
Part 1: Move the protection setting button into the footer section and change the style of the footer section. r=nhnt11
https://hg.mozilla.org/integration/autoland/rev/0bc58dafb302
Part 2: Add strings for protections panel footer section. r=nhnt11,flod
https://hg.mozilla.org/integration/autoland/rev/2569f3cff021
Part 3: Add the tooltip for showing the earliest record of the blocked tracker. r=nhnt11
https://hg.mozilla.org/integration/autoland/rev/7110eb5e7ab1
Part 4: Implement the number of blocked tracker in the footer section. r=nhnt11
https://hg.mozilla.org/integration/autoland/rev/016f5882a4cb
Part 5: Update the test browser_protections_UI.js. r=nhnt11
Flags: needinfo?(tihuang)
Pushed by tihuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/03f32eed08ab
Part 1: Move the protection setting button into the footer section and change the style of the footer section. r=nhnt11
https://hg.mozilla.org/integration/autoland/rev/7f2b5b8a10a2
Part 2: Add strings for protections panel footer section. r=nhnt11,flod
https://hg.mozilla.org/integration/autoland/rev/424189fc44e9
Part 3: Add the tooltip for showing the earliest record of the blocked tracker. r=nhnt11
https://hg.mozilla.org/integration/autoland/rev/260b25a157dc
Part 4: Implement the number of blocked tracker in the footer section. r=nhnt11
https://hg.mozilla.org/integration/autoland/rev/320e196f42d3
Part 5: Update the test browser_protections_UI.js. r=nhnt11
Blocks: 1570029
Duplicate of this bug: 1570029
Regressions: 1570925
You need to log in before you can comment on or make changes to this bug.