Closed Bug 1555259 Opened 1 year ago Closed 4 months ago

[FTL] Copying from Machinery to Source editor results in a broken string

Categories

(Webtools :: Pontoon, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: flod, Assigned: karskaja, Mentored)

Details

(Whiteboard: outreachyround19)

Attachments

(2 files)

If you have a simple FTL string, and click on one of the machinery items, you'll end up with a broken string (because the ID = part is lost in the process).

As bug 1555239, this might end up being a WONTFIX, if we decide that it's going to be fixed by having the rich UI.

Priority: -- → P3

(In reply to Francesco Lodolo [:flod] from comment #0)

As bug 1555239, this might end up being a WONTFIX, if we decide that it's going to be fixed by having the rich UI.

Actually, I realized this shouldn't be true. This would be a regression from the current behavior when in FTL advanced mode, we should just account for the ID when copying from MACHINERY.

Good call - we should make sure copying from Machinery results in a valid string by simply prepending "key = " to the string.

The same thing happens in Source editor in Translate.Current, so I'm removing this from the list of Translate.Next bugs.

Summary: [Translate.Next] Copying FTL string from machinery is broken → [FTL] Copying from Machinery to Source editor results in a broken string
Mentor: m

Hello. I'm an Outreachy applicant, is this bug still available?

Flags: needinfo?(m)

Andreja, the bug is now assigned to you! Please let me know if you have any questions, either here or in #pontoon on IRC.

You can start by installing Pontoon locally using Docker.

Once you have a working local environment, please make sure to read our contribution docs. It contains information on how to style code, how to run tests, how to name your commits, etc. All the things you need to know if you want your work to be merged into Pontoon!

Assignee: nobody → andreja.prpic
Status: NEW → ASSIGNED
Flags: needinfo?(m)

Thank you!

Hello. I couldn't install Docker Desktop because I have Windows 10 Home (instead of Pro or Enterprise), even with Hyper-V activated. Is it ok if I install Docker Toolbox which includes Virtual Box?

Andreja, sadly I don't know for sure, but looking at https://docs.docker.com/toolbox/toolbox_install_windows/ and https://forums.docker.com/t/installing-docker-on-windows-10-home/11722/2, I would assume the answer is "Yes".

Great, thanks!

Hello. I installed Docker Toolbox on my Windows 10 home successfully and did all other steps (https://mozilla-pontoon.readthedocs.io/en/latest/dev/setup.html) until I got this error after running Make build:

Step 6/28 : COPY docker/set_up_ubuntu.sh /tmp/set_up_ubuntu.sh
 ---> Using cache
 ---> 198fc31fd11c
Step 7/28 : RUN /tmp/set_up_ubuntu.sh
 ---> Running in 0e903cdc52c4
/bin/sh: 1: /tmp/set_up_ubuntu.sh: not found
ERROR: Service 'webapp' failed to build: The command '/bin/sh -c /tmp/set_up_ubuntu.sh' returned a non-zero code: 127
make: *** [build] Error 1

I googled it but didn't find a solution.
Thanks!

Andreja, sorry for responding so late - seems like the notification email fell through the cracks. :/ I haven't seen this error before and I don't know out of my head what's going wrong. I wonder if it's related to Docker Toolbox. Let's sync on IRC if you're still experiencing this issue.

--

We're getting lots of requests by Outreachy participants, so we often run out of Mentored bugs. We've decided to unassign all Mentored bugs until the assignee sets up a development environment.

Please send us a screenshot of your working development environment via #pontoon on Mozilla IRC and we'll assign you a Mentored bug afterwards.

Thanks for understanding!

Assignee: andreja.prpic → nobody
Status: ASSIGNED → NEW

No problem. Yes, good that you unassigned it, I felt guilty about having it assigned to me :). I started working on another project, I think I am not yet qualified enough to work on the bugs. Thanks.

Can I take this one?

Anastasia, I've assigned you https://bugzilla.mozilla.org/show_bug.cgi?id=1564841, which is a little more challenging. :)

Let's sync via email/IRC if you want to work on something else instead or if you need anything else.

@mathjazz, can I try with this one?

Assignee: nobody → karskaja
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Whiteboard: outreachyround19
You need to log in before you can comment on or make changes to this bug.