Closed Bug 1555277 Opened 3 months ago Closed 3 months ago

search engine name autocomplete bug in url bar when pressing enter key

Categories

(Firefox :: Address Bar, defect, P3)

69 Branch
defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 69
Iteration:
69.2 - May 27 - Jun 9
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- disabled
firefox68 --- verified
firefox69 --- verified

People

(Reporter: tripurari001, Assigned: mak)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

suppose your default search is duckduckgo and you want to search something with google

  1. goto url input bar
  2. type @goo
  3. now you can see the suggestions google is highlighted
  4. pressing enter key do not have any effect

refer to gif attachment

Actual results:

when search-engine suggestion is highlighted in url bar it do not auto-complete on pressing enter key

Expected results:

if a suggestion of search engine is highlighted it should be completed ( with a extra space character after it ) on pressing enter key

Component: Untriaged → Address Bar

tentatively blocking QB release while we investigate the problem.

I can reproduce the issue on Nightly69.0a1 and Beta68.0b5 Windows10, but not on Firefox67.0.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=d1f9cf74a077fe71234115dafdee9c0723b58e93&tochange=a8fcad5870bad1bc7d9b355e2b3348753f7385c7

Regressed by:a8fcad5870bad1bc7d9b355e2b3348753f7385c7 Mike de Boer — Bug 1548031 - Enable the QuantumBar on Nightly and early Beta. r=adw

Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Thanks For you quick response

  1. I did not see any error message in console while it's happen

  2. Happened in Safe mode as well

Earlier it used to work fine It was in recent updates ( in nightly and developer edition ) I saw this bug

Flags: needinfo?(tripurari001)

(In reply to Marco Bonardo [::mak] from comment #1)

Hm, for me when I press enter @google is autocompleted, and the caret moves 1 space after it. Though I didn't test on Mac, so maybe there's a relation with the OS.

Do you see any error in the browser console when this happens?
Do you have any userChrome.css modifications?
does it happen in Safe Mode? https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

and

  1. I don't have any userChrome.css changes

Thanks for reporting this.

To clarify, with both awesomebar and quantumbar, once you type @goo it's autofilled to @google. If you hit enter at this point, with awesomebar, the caret moves to the end; with quantumbar, nothing happens. In both awesomebar and quantumbar, if you keep hitting enter after that, nothing happens.

I don't think this blocks quantumbar release, so I'm going to remove that dependency. @google still gets autofilled, it's just that the caret doesn't move to the end when you press enter. Instead you have to press the right arrow key, which you could also do with awesomebar.

I'd like to fix this soon, though.

Priority: -- → P3

I figured out that I had QB disabled because of some previous testing last week, and that's why I couldn't reproduce.
After being able to try, to me the bug looks bad enough, it's a regression and makes the search experience in this specific case horrible, one has to type the whole alias before being able to search, that makes autofill pretty much pointless. I think we should fix and uplift a fix, or at least rise this issue with mconnor and see what he thinks.

I'm looking into this, anyway

Assignee: nobody → mak77
Status: NEW → ASSIGNED
Iteration: --- → 69.2 - May 27 - Jun 9
Points: --- → 2

What? The alias autofills, at least for me here. What I wrote in my comment.

Iteration: 69.2 - May 27 - Jun 9 → ---
Points: 2 → ---
Flags: needinfo?(mak77)

it autofills, but its unusable until you finish typing it.

Flags: needinfo?(mak77)

It's not unusable, you can hit the right arrow key to move the caret to the end, just like you can with any autofilled string.

it breaks muscle memory if one is used to press Enter. I agree with not considering it a P1, but it would still be terrible for someone used to confirm with Enter.

Iteration: --- → 69.2 - May 27 - Jun 9
Points: --- → 2

(In reply to Marco Bonardo [::mak] from comment #12)

it breaks muscle memory if one is used to press Enter. I agree with not considering it a P1, but it would still be terrible for someone used to confirm with Enter.

I agree with you Marco it was really bad experience for me bad enough that i created account on Bugzilla and submitted my first bug :p

anyways
Thanks such a great product a your hard work guys I love this community

Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/982bd68986d6
In Quantum Bar @aliases can't be autofilled with Enter. r=adw
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Fixed on latest Nightly.

Status: RESOLVED → VERIFIED

Do you want to request uplift to 68?

Flags: needinfo?(mak77)

Comment on attachment 9068863 [details]
Bug 1555277 - In Quantum Bar @aliases can't be autofilled with Enter. r=adw

Beta/Release Uplift Approval Request

  • User impact if declined: Typing a partial @alias (like the ones we have for some of the default search engines) can't be confirmed anymore with Enter, so the user has either to press RIGHT (possibly breaking their muscle memory and interrupting the workflow) or keep typing the whole alias.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: type "@go" check "@google" is autofilled, press Enter, "@google " should be completed and the cursor should be after the trailing space, in the proper position to start typing a query string
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Trivial patch, pretty much only moving the cursor to the appropriate position, has test.
  • String changes made/needed: none
Flags: needinfo?(mak77)
Attachment #9068863 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9068863 [details]
Bug 1555277 - In Quantum Bar @aliases can't be autofilled with Enter. r=adw

quantumbar autofill fix, approved for 68.0b8

Attachment #9068863 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

I have managed to reproduce this issue using Firefox 69.0a1 (BuildId:20190520215528). This issue is verified fixed using Firefox 68.0b8 (provided in comment 21 ) on Windows 10 64bit, macOS 10.14 and Ubuntu 18.04 64bit.

Flags: qe-verify+
Regressions: 1557302
Depends on: 1557302
No longer regressions: 1557302
You need to log in before you can comment on or make changes to this bug.