Closed Bug 1555382 Opened 6 months ago Closed 6 months ago

Perma browser chrome browser_navigation_process_swap.js should load in a web-content process - "file" == "web" when Gecko 69 merges to Beta on 19-07-01

Categories

(Core :: DOM: Navigation, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla69
Fission Milestone M3
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 + fixed
firefox69 + verified

People

(Reporter: CosminS, Assigned: Nika)

References

Details

(Keywords: regression, Whiteboard: [stockwell needswork:owner])

Attachments

(1 file)

Central as beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception&revision=c91addf88fc3ecc711c491f0a6fb5beba9677fcd&searchStr=browser%2Cchrome&selectedJob=248954959

Failure log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=248954959&repo=try&lineNumber=5112
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=248948528&repo=try&lineNumber=23668

14:07:58 INFO - TEST-PASS | dom/serviceworkers/test/browser_navigation_process_swap.js | file:///Users/cltbld/tasks/task_1559137889/build/tests/mochitest/browser/dom/serviceworkers/test/empty.html should load in a file process - "file" == "file" -
14:07:58 INFO - Dynamically creating file:///Users/cltbld/tasks/task_1559137889/build/tests/mochitest/browser/dom/serviceworkers/test/empty.html's link
14:07:58 INFO - Starting navigation
14:07:58 INFO - Waiting for location to change to http://example.com/browser/dom/serviceworkers/test/empty_with_utils.html
14:07:58 INFO - Waiting for the browser to stop
14:07:58 INFO - Console message: [JavaScript Error: "RemoteWebProgress failed to call onProgressChange: [Exception... "JavaScript component does not have a method named: "onProgressChange"'JavaScript component does not have a method named: "onProgressChange"' when calling method: [nsIWebProgressListener::onProgressChange]" nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)" location: "JS frame :: resource://gre/modules/RemoteWebProgress.jsm :: _callProgressListeners :: line 101" data: no]
14:07:58 INFO - " {file: "resource://gre/modules/RemoteWebProgress.jsm" line: 103}]
14:07:58 INFO - _callProgressListeners@resource://gre/modules/RemoteWebProgress.jsm:103:14
14:07:58 INFO - onProgressChange@resource://gre/modules/RemoteWebProgress.jsm:118:10
14:07:58 INFO -
14:07:58 INFO - Buffered messages finished
14:07:58 INFO - TEST-UNEXPECTED-FAIL | dom/serviceworkers/test/browser_navigation_process_swap.js | http://example.com/browser/dom/serviceworkers/test/empty_with_utils.html should load in a web-content process - "file" == "web" - JS frame :: chrome://mochitests/content/browser/dom/serviceworkers/test/browser_navigation_process_swap.js :: runTest :: line 106
14:07:58 INFO - Stack trace:
14:07:58 INFO - chrome://mochitests/content/browser/dom/serviceworkers/test/browser_navigation_process_swap.js:runTest:106
14:07:58 INFO - Loading initial page to unregister all Service Workers
14:07:58 INFO - Unregistering all Service Workers
14:07:58 INFO - Closing tab
14:07:58 INFO - Leaving test bound runTest
14:07:58 INFO - GECKO(1210) | MEMORY STAT | vsize 5409MB | residentFast 296MB | heapAllocated 136MB
14:07:58 INFO - TEST-OK | dom/serviceworkers/test/browser_navigation_process_swap.js | took 1346ms

Could this be from https://hg.mozilla.org/mozilla-central/rev/1d376f00f17e, Bug 1554217? Nika, do you mind taking a look?

Summary: Perm browser chrome browser_navigation_process_swap.js|browser_oopProcessSwap.js should load in a web-content process - "file" == "web" when Gecko 69 merges to Beta on 19-07-01 → Perma browser chrome browser_navigation_process_swap.js|browser_oopProcessSwap.js should load in a web-content process - "file" == "web" when Gecko 69 merges to Beta on 19-07-01

Seems likely it's caused by the pref not being set, yes. I've put together a patch to force it on for this test.

Flags: needinfo?(nika)
Assignee: nobody → nika
Fission Milestone: --- → M3
Priority: -- → P2

On release I went with making the test's assertion conditional at https://hg.mozilla.org/releases/mozilla-release/diff/fb5d546bb5b3c583a41225376e3e5a3674f90640/dom/serviceworkers/test/browser_navigation_process_swap.js that landed in https://bugzilla.mozilla.org/show_bug.cgi?id=1535699#c36

Should we do that instead? Or I think we're imminently going to uplift bug 1551601 and flip the pref back so the test will be happy?

Summary: Perma browser chrome browser_navigation_process_swap.js|browser_oopProcessSwap.js should load in a web-content process - "file" == "web" when Gecko 69 merges to Beta on 19-07-01 → Perma browser chrome browser_navigation_process_swap.js should load in a web-content process - "file" == "web" when Gecko 69 merges to Beta on 19-07-01

Wrong test, that one is bug 1555688.

Flags: needinfo?(nika)
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cf8450a34236
Force httpResponseProcessSelection on for browser_navigation_process_swap, r=asuth
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Whiteboard: [stockwell needswork:owner] → [stockwell needswork:owner][checkin-needed beta]
Whiteboard: [stockwell needswork:owner][checkin-needed beta] → [stockwell needswork:owner]
You need to log in before you can comment on or make changes to this bug.