Closed Bug 1555435 Opened 10 months ago Closed 10 months ago

Assertion failure: newScheme == scheme, at /builds/worker/workspace/build/src/netwerk/base/nsNetUtil.cpp:1874

Categories

(Core :: Networking, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1555302
Tracking Status
firefox69 --- affected

People

(Reporter: tsmith, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, crash, testcase)

Attachments

(1 file)

Attached file testcase.html

Reduced with m-c:
BuildID=20190529155828
SourceStamp=2bb77ed1fcc5ad06f91612d419160f54c09369db

Assertion failure: newScheme == scheme, at src/netwerk/base/nsNetUtil.cpp:1878

#0 ~nsCOMPtr_base src/obj-firefox/dist/include/nsCOMPtr.h:331:7
#1 ~NS_MutateURI src/obj-firefox/dist/include/nsIURIMutator.h:455
#2 NS_NewURI(nsIURI**, nsTSubstring<char> const&, char const*, nsIURI*, nsIIOService*) src/netwerk/base/nsNetUtil.cpp:1891
#3 NS_NewURI(nsIURI**, nsTSubstring<char> const&, mozilla::NotNull<mozilla::Encoding const*>, nsIURI*, nsIIOService*) src/netwerk/base/nsNetUtil.cpp:1636:10
#4 NS_NewURI(nsIURI**, nsTSubstring<char16_t> const&, mozilla::NotNull<mozilla::Encoding const*>, nsIURI*, nsIIOService*) src/netwerk/base/nsNetUtil.cpp:1662:10
#5 mozilla::dom::SetBaseURIUsingFirstBaseWithHref(mozilla::dom::Document*, nsIContent*) src/dom/html/HTMLSharedElement.cpp:146:7
#6 mozilla::dom::HTMLSharedElement::AfterSetAttr(int, nsAtom*, nsAttrValue const*, nsAttrValue const*, nsIPrincipal*, bool) src/dom/html/HTMLSharedElement.cpp:210:9
#7 mozilla::dom::Element::SetAttrAndNotify(int, nsAtom*, nsAtom*, nsAttrValue const*, nsAttrValue&, nsIPrincipal*, unsigned char, bool, bool, bool, mozilla::dom::Document*, mozAutoDocUpdate const&) src/dom/base/Element.cpp:2535:10
#8 mozilla::dom::Element::SetAttr(int, nsAtom*, nsAtom*, nsTSubstring<char16_t> const&, nsIPrincipal*, bool) src/dom/base/Element.cpp:2399:10
#9 SetAttr src/obj-firefox/dist/include/mozilla/dom/Element.h:837:12
#10 SetAttr src/obj-firefox/dist/include/mozilla/dom/Element.h:833
#11 SetAttr src/obj-firefox/dist/include/mozilla/dom/Element.h:1560
#12 SetHTMLAttr src/dom/html/nsGenericHTMLElement.h:713
#13 SetHref src/obj-firefox/dist/include/mozilla/dom/HTMLSharedElement.h:98
#14 mozilla::dom::HTMLBaseElement_Binding::set_href(JSContext*, JS::Handle<JSObject*>, mozilla::dom::HTMLSharedElement*, JSJitSetterCallArgs) src/obj-firefox/dom/bindings/HTMLBaseElementBinding.cpp:67
#15 bool mozilla::dom::binding_detail::GenericSetter<mozilla::dom::binding_detail::NormalThisPolicy>(JSContext*, unsigned int, JS::Value*) src/dom/bindings/BindingUtils.cpp:3118:8
#16 CallJSNative src/js/src/vm/Interpreter.cpp:448:13
#17 js::InternalCallOrConstruct(JSContext*, JS::CallArgs const&, js::MaybeConstruct) src/js/src/vm/Interpreter.cpp:540
#18 InternalCall src/js/src/vm/Interpreter.cpp:595:10
#19 Call src/js/src/vm/Interpreter.cpp:611
#20 js::CallSetter(JSContext*, JS::Handle<JS::Value>, JS::Handle<JS::Value>, JS::Handle<JS::Value>) src/js/src/vm/Interpreter.cpp:749
#21 SetExistingProperty(JSContext*, JS::Handle<JS::PropertyKey>, JS::Handle<JS::Value>, JS::Handle<JS::Value>, JS::Handle<js::NativeObject*>, JS::Handle<JS::PropertyResult>, JS::ObjectOpResult&) src/js/src/vm/NativeObject.cpp:2926:8
#22 bool js::NativeSetProperty<(js::QualifiedBool)1>(JSContext*, JS::Handle<js::NativeObject*>, JS::Handle<JS::PropertyKey>, JS::Handle<JS::Value>, JS::Handle<JS::Value>, JS::ObjectOpResult&) src/js/src/vm/NativeObject.cpp:2955:14
#23 SetProperty src/js/src/vm/ObjectOperations-inl.h:283:10
#24 SetPropertyOperation src/js/src/vm/Interpreter.cpp:270
#25 Interpret(JSContext*, js::RunState&) src/js/src/vm/Interpreter.cpp:2852
#26 js::RunScript(JSContext*, js::RunState&) src/js/src/vm/Interpreter.cpp:425:10
#27 js::InternalCallOrConstruct(JSContext*, JS::CallArgs const&, js::MaybeConstruct) src/js/src/vm/Interpreter.cpp:568:13
#28 js::Call(JSContext*, JS::Handle<JS::Value>, JS::Handle<JS::Value>, js::AnyInvokeArgs const&, JS::MutableHandle<JS::Value>) src/js/src/vm/Interpreter.cpp:611:8
#29 JS::Call(JSContext*, JS::Handle<JS::Value>, JS::Handle<JS::Value>, JS::HandleValueArray const&, JS::MutableHandle<JS::Value>) src/js/src/jsapi.cpp:2654:10
#30 mozilla::dom::EventHandlerNonNull::Call(JSContext*, JS::Handle<JS::Value>, mozilla::dom::Event&, JS::MutableHandle<JS::Value>, mozilla::ErrorResult&) src/obj-firefox/dom/bindings/EventHandlerBinding.cpp:267:37
#31 Call<nsCOMPtr<mozilla::dom::EventTarget> > src/obj-firefox/dist/include/mozilla/dom/EventHandlerBinding.h:363:12
#32 mozilla::JSEventHandler::HandleEvent(mozilla::dom::Event*) src/dom/events/JSEventHandler.cpp:205
#33 mozilla::EventListenerManager::HandleEventSubType(mozilla::EventListenerManager::Listener*, mozilla::dom::Event*, mozilla::dom::EventTarget*) src/dom/events/EventListenerManager.cpp:1041:22
#34 mozilla::EventListenerManager::HandleEventInternal(nsPresContext*, mozilla::WidgetEvent*, mozilla::dom::Event**, mozilla::dom::EventTarget*, nsEventStatus*, bool) src/dom/events/EventListenerManager.cpp:1239:17
#35 HandleEvent src/obj-firefox/dist/include/mozilla/EventListenerManager.h:353:5
#36 mozilla::EventTargetChainItem::HandleEvent(mozilla::EventChainPostVisitor&, mozilla::ELMCreationDetector&) src/dom/events/EventDispatcher.cpp:349
#37 mozilla::EventTargetChainItem::HandleEventTargetChain(nsTArray<mozilla::EventTargetChainItem>&, mozilla::EventChainPostVisitor&, mozilla::EventDispatchingCallback*, mozilla::ELMCreationDetector&) src/dom/events/EventDispatcher.cpp:551:16
#38 mozilla::EventDispatcher::Dispatch(nsISupports*, nsPresContext*, mozilla::WidgetEvent*, mozilla::dom::Event*, nsEventStatus*, mozilla::EventDispatchingCallback*, nsTArray<mozilla::dom::EventTarget*>*) src/dom/events/EventDispatcher.cpp:1047:11
#39 nsDocumentViewer::LoadComplete(nsresult) src/layout/base/nsDocumentViewer.cpp:1105:7
#40 nsDocShell::EndPageLoad(nsIWebProgress*, nsIChannel*, nsresult) src/docshell/base/nsDocShell.cpp:6662:20
#41 nsDocShell::OnStateChange(nsIWebProgress*, nsIRequest*, unsigned int, nsresult) src/docshell/base/nsDocShell.cpp:6462:7
#42 non-virtual thunk to nsDocShell::OnStateChange(nsIWebProgress*, nsIRequest*, unsigned int, nsresult) src/docshell/base/nsDocShell.cpp
#43 nsDocLoader::DoFireOnStateChange(nsIWebProgress*, nsIRequest*, int&, nsresult) src/uriloader/base/nsDocLoader.cpp:1315:3
#44 nsDocLoader::doStopDocumentLoad(nsIRequest*, nsresult) src/uriloader/base/nsDocLoader.cpp:874:14
#45 nsDocLoader::DocLoaderIsEmpty(bool) src/uriloader/base/nsDocLoader.cpp:712:9
#46 nsDocLoader::OnStopRequest(nsIRequest*, nsresult) src/uriloader/base/nsDocLoader.cpp:600:5
#47 non-virtual thunk to nsDocLoader::OnStopRequest(nsIRequest*, nsresult) src/uriloader/base/nsDocLoader.cpp
#48 mozilla::net::nsLoadGroup::RemoveRequest(nsIRequest*, nsISupports*, nsresult) src/netwerk/base/nsLoadGroup.cpp:568:22
#49 DoUnblockOnload src/dom/base/Document.cpp:8747:18
#50 mozilla::dom::Document::UnblockOnload(bool) src/dom/base/Document.cpp:8679
#51 mozilla::dom::Document::DispatchContentLoadedEvents() src/dom/base/Document.cpp:5160:3
#52 applyImpl<mozilla::dom::Document, void (mozilla::dom::Document::*)()> src/obj-firefox/dist/include/nsThreadUtils.h:1122:12
#53 apply<mozilla::dom::Document, void (mozilla::dom::Document::*)()> src/obj-firefox/dist/include/nsThreadUtils.h:1128
#54 mozilla::detail::RunnableMethodImpl<mozilla::dom::Document*, void (mozilla::dom::Document::*)(), true, (mozilla::RunnableKind)0>::Run() src/obj-firefox/dist/include/nsThreadUtils.h:1174
#55 mozilla::SchedulerGroup::Runnable::Run() src/xpcom/threads/SchedulerGroup.cpp:295:32
#56 nsThread::ProcessNextEvent(bool, bool*) src/xpcom/threads/nsThread.cpp:1176:14
#57 NS_ProcessNextEvent(nsIThread*, bool) src/xpcom/threads/nsThreadUtils.cpp:486:10
#58 mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) src/ipc/glue/MessagePump.cpp:88:21
#59 RunInternal src/ipc/chromium/src/base/message_loop.cc:315:10
#60 RunHandler src/ipc/chromium/src/base/message_loop.cc:308
#61 MessageLoop::Run() src/ipc/chromium/src/base/message_loop.cc:290
#62 nsBaseAppShell::Run() src/widget/nsBaseAppShell.cpp:137:27
#63 XRE_RunAppShell() src/toolkit/xre/nsEmbedFunctions.cpp:911:20
#64 RunInternal src/ipc/chromium/src/base/message_loop.cc:315:10
#65 RunHandler src/ipc/chromium/src/base/message_loop.cc:308
#66 MessageLoop::Run() src/ipc/chromium/src/base/message_loop.cc:290
#67 XRE_InitChildProcess(int, char**, XREChildData const*) src/toolkit/xre/nsEmbedFunctions.cpp:749:34
#68 content_process_main src/browser/app/../../ipc/contentproc/plugin-container.cpp:56:28
#69 main src/browser/app/nsBrowserApp.cpp:263
Flags: in-testsuite?

Valentin, could you also take a look?

Flags: needinfo?(valentin.gosu)
Status: NEW → RESOLVED
Closed: 10 months ago
Flags: needinfo?(valentin.gosu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1555302
You need to log in before you can comment on or make changes to this bug.