Open Bug 1555529 Opened 3 years ago Updated 3 years ago

Tracking protection blocks stylesheets from cdn-images.mailchimp.com

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

67 Branch
defect

Tracking

()

REOPENED

People

(Reporter: maria, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [tp-needsrepro][tp-yellowlist-passive][tp-embedded-media])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

I navigated to the following site on a private Firefox browser: https://www.bootsroad.com/web
Scrolled to the bottom to see the Mailchimp contact form.

Actual results:

The styling for the contact form does not render even though any other private browser renders without issues.

Expected results:

It should render the <link> that points to Mailchimp's CDN.

OS: Unspecified → macOS
Hardware: Unspecified → Desktop

Chrome private and Safari private renders correctly.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0
20190529215251

The resource at “https://cdn-images.mailchimp.com/embedcode/classic-10_7.css” was blocked because content blocking is enabled.

Blocks: tp-breakage
Status: UNCONFIRMED → NEW
Component: Untriaged → Tracking Protection
Ever confirmed: true
OS: macOS → All
Hardware: Desktop → All
See Also: → 1449372
Summary: Private Firefox completely ignores Mailchimp's styling: <link> → Tracking protection blocks stylesheets from cdn-images.mailchimp.com
Priority: -- → P3
Whiteboard: [tp-needsrepro]
Component: Protections UI → Privacy: Anti-Tracking
Product: Firefox → Core
Duplicate of this bug: 1598990
No longer blocks: 1598990

From bug 1598990, gallery.mailchimp.com is blocked as well => blocking images
Test case: https://ajsmart.us3.list-manage.com/subscribe?u=1ca8e8abc4532cf5eda333a1f&id=6c86582d80

The contact form seems to render fine now, and I don't see any mailchimp resources being blocked, so I think this is fixed (maybe they just stopped using mailchimp).

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME

Ah, I didn't notice that last comment; indeed, the images on that link aren't loading in strict mode due to the Mailchimp CDN resources being blocked. I'll re-open this bug.

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
No longer blocks: tp-breakage

The css still seems to get blocked, see the form on https://www.recyclesmart.com/ at the bottom, just after "Let's stay connected!".

Warning in the console:

The resource at “https://cdn-images.mailchimp.com/embedcode/classic-10_7.css” was blocked because content blocking is enabled.

Whiteboard: [tp-needsrepro] → [tp-needsrepro][tp-yellowlist-passive][tp-embedded-media]
You need to log in before you can comment on or make changes to this bug.