If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

brower crashed after saving an image

VERIFIED DUPLICATE of bug 132905

Status

SeaMonkey
Bookmarks & History
--
critical
VERIFIED DUPLICATE of bug 132905
15 years ago
13 years ago

People

(Reporter: proctor, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Right clicked an image and chosed "Save Image As.." , right after the image is
saved, the browser crashed.
(Reporter)

Comment 1

15 years ago
Incident ID:
TB7955211K
TB7955091Z
TB7954399X

Comment 2

15 years ago
Please provide build number, url etc...
(Reporter)

Comment 3

15 years ago
I am using:
Windows 2000
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a+) Gecko/20020702

It crashes anytime after I "Save Image AS...". It happens with the banner on top
of this Mozilla site too.

Updated

15 years ago
Severity: normal → critical
Keywords: crash, stackwanted
Whiteboard: Need TB7955211K data

Comment 4

15 years ago
Here's the stack from the first incident (7955211):

Product ID MozillaTrunk
Build ID 2002061104
Trigger Time 2002-07-03 03:39:35
Platform Win32
Operating System Windows NT 5.0 build 2195
Module gkcontent.dll
URL visited try downloading new version of Mozilla (1.1a+)

User Comments right clicked an image and choosed "Save Image As...". The broswer
crashed right after the image is saved.

Stack Trace
nsAssignmentSet::GetAssignmentFor [nsRuleNetwork.cpp, line 596]
nsTemplateMatch::GetAssignmentFor [nsTemplateMatch.cpp, line 52]
nsXULTemplateBuilder::SubstituteTextReplaceVariable [nsXULTemplateBuilder.cpp,
line 1168]
nsXULTemplateBuilder::ParseAttribute [nsXULTemplateBuilder.cpp, line 1077]
nsXULTemplateBuilder::SubstituteText [nsXULTemplateBuilder.cpp, line 1125]
nsXULContentBuilder::BuildContentFromTemplate [nsXULContentBuilder.cpp, line 783]
nsXULContentBuilder::CreateTemplateContents [nsXULContentBuilder.cpp, line 1385]
nsXULContentBuilder::CreateTemplateAndContainerContents
[nsXULContentBuilder.cpp, line 1209]
nsXULContentBuilder::CreateContents [nsXULContentBuilder.cpp, line 1765]
nsXULElement::EnsureContentsGenerated [nsXULElement.cpp, line 3654]
nsXULElement::ChildCount [nsXULElement.cpp, line 2175]
nsXULElement::GetChildNodes [nsXULElement.cpp, line 768]
nsXULElement::GetElementsByTagName [nsXULElement.cpp, line 3684]
nsXULElement::GetElementsByTagName [nsXULElement.cpp, line 3718]
nsXULElement::GetElementsByTagName [nsXULElement.cpp, line 3718]
nsXULElement::GetElementsByTagName [nsXULElement.cpp, line 3718]
nsXULElement::GetElementsByTagName [nsXULElement.cpp, line 1425]
XPTC_InvokeByIndex [xptcinvoke.cpp, line 106]
XPCWrappedNative::CallMethod [xpcwrappednative.cpp, line 1996]
XPC_WN_CallMethod [xpcwrappednativejsops.cpp, line 1267]
js_Invoke [jsinterp.c, line 790]
js_Interpret [jsinterp.c, line 2744]
js_Invoke [jsinterp.c, line 806]
js_InternalInvoke [jsinterp.c, line 881]
JS_CallFunctionValue [jsapi.c, line 3426]
nsJSContext::CallEventHandler [nsJSEnvironment.cpp, line 1045]
nsJSEventListener::HandleEvent [nsJSEventListener.cpp, line 184]
nsXBLPrototypeHandler::ExecuteHandler [nsXBLPrototypeHandler.cpp, line 448]
nsXBLPrototypeHandler::BindingAttached [nsXBLPrototypeHandler.cpp, line 496]
nsXBLPrototypeBinding::BindingAttached [nsXBLPrototypeBinding.cpp, line 441]
nsXBLBinding::ExecuteAttachedHandler [nsXBLBinding.cpp, line 1040]
nsBindingManager::ProcessAttachedQueue [nsBindingManager.cpp, line 913]
nsCSSFrameConstructor::ContentInserted [nsCSSFrameConstructor.cpp, line 9098]
nsCSSFrameConstructor::ContentAppended [nsCSSFrameConstructor.cpp, line 8258]
StyleSetImpl::ContentAppended [nsStyleSet.cpp, line 1527]
PresShell::ContentAppended [nsPresShell.cpp, line 5300]
nsXULDocument::ContentAppended [nsXULDocument.cpp, line 2256]
nsXULContentBuilder::Rebuild [nsXULContentBuilder.cpp, line 1744]
nsXULContentBuilder::Rebuild [nsXULContentBuilder.cpp, line 1753]
XPTC_InvokeByIndex [xptcinvoke.cpp, line 106]
XPCWrappedNative::CallMethod [xpcwrappednative.cpp, line 1996]
XPC_WN_CallMethod [xpcwrappednativejsops.cpp, line 1267]
js_Invoke [jsinterp.c, line 790]
js_Interpret [jsinterp.c, line 2744]
js_Invoke [jsinterp.c, line 806]
js_InternalInvoke [jsinterp.c, line 881]
JS_CallFunctionValue [jsapi.c, line 3426]
nsJSContext::CallEventHandler [nsJSEnvironment.cpp, line 1045]
nsJSEventListener::HandleEvent [nsJSEventListener.cpp, line 184]
nsEventListenerManager::HandleEventSubType [nsEventListenerManager.cpp, line 1222]
nsEventListenerManager::HandleEvent [nsEventListenerManager.cpp, line 1904]
GlobalWindowImpl::HandleDOMEvent [nsGlobalWindow.cpp, line 733]
DocumentViewerImpl::LoadComplete [nsDocumentViewer.cpp, line 1558]
nsDocShell::EndPageLoad [nsDocShell.cpp, line 3957]
nsWebShell::EndPageLoad [nsWebShell.cpp, line 731]
nsDocShell::OnStateChange [nsDocShell.cpp, line 3871]
nsDocLoaderImpl::FireOnStateChange [nsDocLoader.cpp, line 1112]
nsDocLoaderImpl::doStopDocumentLoad [nsDocLoader.cpp, line 771]
nsDocLoaderImpl::DocLoaderIsEmpty [nsDocLoader.cpp, line 669]
nsDocLoaderImpl::OnStopRequest [nsDocLoader.cpp, line 600]
nsLoadGroup::RemoveRequest [nsLoadGroup.cpp, line 537]
imgRequestProxy::OnStopRequest [imgRequestProxy.cpp, line 392]
imgRequest::OnStopRequest [imgRequest.cpp, line 648]
ProxyListener::OnStopRequest [imgLoader.cpp, line 706]

Comment 5

15 years ago
...which makes it a duplicate of 132905. Marking so.

*** This bug has been marked as a duplicate of 132905 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Keywords: stackwanted
Resolution: --- → DUPLICATE
Whiteboard: Need TB7955211K data

Comment 6

15 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.