Closed Bug 1555691 Opened 3 years ago Closed 3 years ago

Crash in [@ java.lang.NullPointerException: at org.mozilla.gecko.media.RemoteManager.releaseCodec(RemoteManager.java)]

Categories

(Firefox for Android Graveyard :: Audio/Video, defect, P1)

Firefox 68
Unspecified
Android
defect

Tracking

(firefox67 unaffected, firefox68 fixed, firefox69 fixed)

RESOLVED FIXED
Firefox 69
Tracking Status
firefox67 --- unaffected
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: marcia, Assigned: jhlin)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-f787c370-bc9d-4c14-bd6a-72e5f0190530.

Seen while looking at 68 beta crash stats: https://mzl.la/2WE9Ehm. This started as a small volume crash in 68 nightly and has carried into beta. Crashes in 68 nightly started in 20190511094814

Possible regression range based on build id: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d9d0399a6baf2f0677586b79f3195d39b2119f97&tochange=2f94885dcf94f823f37c99231c79146b6b907e4c

A few correlations:
100.0% in signature vs 01.78% overall) moz_crash_reason = MOZ_CRASH(JNI exception)
(50.00% in signature vs 00.57% overall) adapter_device_id = PowerVR Rogue GE8100 [83.33% vs 10.77% if adapter_vendor_id = Imagination Technologies]
(60.00% in signature vs 05.26% overall) adapter_vendor_id = Imagination Technologies
(50.00% in signature vs 00.40% overall) android_device = U3A_PLUS_4G
(50.00% in signature vs 00.40% overall) android_model = 5033A

Java stack trace:

java.lang.NullPointerException
	at org.mozilla.gecko.media.RemoteManager.releaseCodec(RemoteManager.java:214)
	at org.mozilla.gecko.media.CodecProxy.release(CodecProxy.java:348)
Assignee: nobody → jolin
Status: NEW → ASSIGNED
Priority: -- → P1
Pushed by jolin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3cdc43e0cf78
handle NPE during remote codec shutdown. r=esawin
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

John, just a reminder: we'll need to uplift your fix to Beta because these crashes are reproducible in Fennec 68 Beta.

Flags: needinfo?(jolin)

(In reply to Chris Peterson [:cpeterson] from comment #4)

John, just a reminder: we'll need to uplift your fix to Beta because these crashes are reproducible in Fennec 68 Beta.

Thanks for the reminder! I was about to do it after the patch landed successfully in central. :)

Flags: needinfo?(jolin)

Comment on attachment 9069453 [details]
Bug 1555691 - handle NPE during remote codec shutdown. r?esawin

Beta/Release Uplift Approval Request

  • User impact if declined: Fennec crashes occasionally when codec shuts down. (Caused by bug 1499224)
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The change catches exceptions.
  • String changes made/needed: None
Attachment #9069453 - Flags: approval-mozilla-beta?

Comment on attachment 9069453 [details]
Bug 1555691 - handle NPE during remote codec shutdown. r?esawin

fennec crash fix, approved for beta68

Attachment #9069453 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.