Closed Bug 1555792 Opened 1 year ago Closed 1 year ago

Enable webrtc use of socket process on nightly by default

Categories

(Core :: WebRTC: Networking, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla70
Fission Milestone M4
Tracking Status
firefox70 --- fixed

People

(Reporter: bwc, Assigned: bwc)

References

(Blocks 2 open bugs, Regressed 1 open bug)

Details

Attachments

(5 files, 1 obsolete file)

This includes setting the default value of media.peerconnection.mtransport_process and network.process.enabled to true in nightly, as well as ensuring that spi tests are run in CI iff the '-spi' suffix is present (in other words, CI should always stomp the default value of these prefs).

Blocks: 1531492

Try has some infra failures it looks like, retriggering.

Fission Milestone: --- → M3
Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/54ed41058000
Set the socket-process-isolation prefs to true on nightly. r=mjf
https://hg.mozilla.org/integration/autoland/rev/8cff011ed07a
Ensure that the new default values for nightly have no effect on CI. r=ahal

Backed out 2 changesets (Bug 1555792) for Windows 2012 build bustages

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=windows%2C2012%2Cshippable%2Cbuild&fromchange=586b27e0e8114f514b71558620ca849abea9d477&tochange=c5a178862298231ac3c47b6d4631a2df3c6499c6&selectedJob=250464983

Backout link: https://hg.mozilla.org/integration/autoland/rev/de019903849effdf777f3acb56d37ee31b888305

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=250464983&repo=autoland&lineNumber=47690

22:15:39 INFO - mozmake.EXE[5]: Leaving directory 'z:/task_1559856130/build/src/obj-firefox/browser/tools/mozscreenshots/mozscreenshots/extension'
22:15:42 INFO - mozmake.EXE[2]: Entering directory 'z:/task_1559856130/build/src/obj-firefox'
22:15:42 INFO - z:/task_1559856130/build/src/clang/bin/llvm-profdata.exe merge -o ./merged.profdata ./*.profraw
22:15:42 INFO - error: ./default_6044_random_7401113781408603760_0.profraw: Invalid instrumentation profile data (file header is corrupt)
22:15:42 INFO - Makefile:287: recipe for target 'maybe_clobber_profiledbuild' failed
22:15:42 INFO - mozmake.EXE[2]: *** [maybe_clobber_profiledbuild] Error 1
22:15:42 INFO - mozmake.EXE[2]: Leaving directory 'z:/task_1559856130/build/src/obj-firefox'
22:15:42 INFO - Makefile:186: recipe for target 'profiledbuild' failed
22:15:42 INFO - mozmake.EXE[1]: *** [profiledbuild] Error 2
22:15:42 INFO - client.mk:125: recipe for target 'build' failed
22:15:42 INFO - mozmake.EXE: *** [build] Error 2
22:15:42 INFO - 225 compiler warnings present.
22:15:42 ERROR - Return code: 2
22:15:42 WARNING - setting return code to 2
22:15:42 FATAL - 'mach build -v' did not run successfully. Please check log for errors.
22:15:42 FATAL - Running post_fatal callback...
22:15:42 FATAL - Exiting -1
22:15:42 INFO - [mozharness: 2019-06-06 22:15:42.358000Z] Finished build step (failed)
22:15:42 INFO - Running post-run listener: _parse_build_tests_ccov
22:15:42 INFO - Running post-run listener: _shutdown_sccache
22:15:42 INFO - Running post-run listener: _summarize
22:15:42 ERROR - # TBPL FAILURE #
22:15:42 INFO - [mozharness: 2019-06-06 22:15:42.358000Z] FxDesktopBuild summary:
22:15:42 ERROR - # TBPL FAILURE #
[taskcluster 2019-06-06T22:15:42.376Z] Exit Code: 4294967295
[taskcluster 2019-06-06T22:15:42.376Z] User Time: 15.625ms
[taskcluster 2019-06-06T22:15:42.376Z] Kernel Time: 0s
[taskcluster 2019-06-06T22:15:42.376Z] Wall Time: 42m49.2837397s
[taskcluster 2019-06-06T22:15:42.376Z] Result: FAILED

Flags: needinfo?(docfaraday)

So I saw this failure on try, but a retrigger cleared it up. I had assumed it was infra, because I haven't touched any c++ code in either of these patches. How would touching prefs.js cause the prof builds to corrupt their profile data, anyway?

Flags: needinfo?(docfaraday) → needinfo?(btara)

I can only observe that the bustages seem to start with your changes and seem to turn green on the backout, sorry, can't think how your changes affect the builds.
https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=windows%2C2012%2Cshippable%2Cbuild&fromchange=586b27e0e8114f514b71558620ca849abea9d477&tochange=c5a178862298231ac3c47b6d4631a2df3c6499c6&selectedJob=250464983

Flags: needinfo?(btara)
Depends on: 1558205
Attachment #9069666 - Attachment description: Bug 1555792: Set the socket-process-isolation prefs to true on nightly. r?mjf → Bug 1555792: Set the socket-process-isolation prefs to true on nightly. r=mjf
Attachment #9069668 - Attachment description: Bug 1555792: Ensure that the new default values for nightly have no effect on CI. r?ahal → Bug 1555792: Ensure that the new default values for nightly have no effect on CI. r=ahal

Seeing some weird new errors on android pgo now.

Flags: needinfo?(snorp)

bwc confirmed this won't get done in time for M3, so punting to M4 for now.

Fission Milestone: M3 → M4
Attachment #9071899 - Attachment description: Bug 1555792: (WIP) Try to fix errors on android related to the socket process. Hopefully this doesn't cause problems when the socket process isn't enabled? → Bug 1555792: Update android manifest files to include the socket process. r?snorp

Patch looks right to me!

Flags: needinfo?(snorp)

Looks like putting quotes around --setpref values (like this) prevents them from being parsed by some test-scripts (like this). I am fixing the cases that involve our socket process prefs, but all other uses of --setpref probably need to be fixed, or we need to strip out quotes on them.

Edit: Also, the try push in comment 44 has a lot of failures in OS 10.10 debug browser-chrome mochitests; the socket process was running on these tests, but those tests aren't running against a shippable build, which means that at least in some cases default prefs on nightly-only are applied to non-shippable builds. That might be another bug.

Flags: needinfo?(ahal)

Just so I don't lose track of it, this is the baseline for comparisons:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=a630530d0bf03f3fe7b8607de22cce3817da9d66

Thanks for the heads up.. though I'm pretty sure at least the fission case is working (due to there being tons of errors everywhere). Maybe Gecko is stripping off the extra quotes in that case though.

Either way, we might as well fix this in the pref parsing function.

Flags: needinfo?(ahal)

Seeing a strange failure in bc9 on OS 10.10 debug. Not sure if that's preexisting, trying to figure that out.

Ok... retriggers are failing here too.

Looks like bug 1459355 is preventing me from retriggering the jobs I need to.

Yeah, those look similar.

No longer depends on: 1558205
Attachment #9071669 - Attachment is obsolete: true

Right. Retriggers are just getting /dev/nulled for that task, apparently. Awesome.

I did see the same failure yesterday on a different bug, so it is probably a pre-existing intermittent.

Now I get to check talos out. Fun.

Regressions: 1563224
No longer regressions: 1563224

Retriggering some talos runs. Also, I need to run talos on baseline on try, since talos on try sometimes performs very differently than on m-c.

Talos looks fine.

Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e9b36f76244b
Set the socket-process-isolation prefs to true on nightly. r=mjf
https://hg.mozilla.org/integration/autoland/rev/0cb155d5d76a
Ensure that the new default values for nightly have no effect on CI. r=ahal
https://hg.mozilla.org/integration/autoland/rev/c0e887e7fc78
Update android manifest files to include the socket process. r=snorp
https://hg.mozilla.org/integration/autoland/rev/c4e7dc6befff
Add --setpref option to many test types r=ahal
https://hg.mozilla.org/integration/autoland/rev/8ec55eb4aed6
Disable the socket process if e10s is disabled. r=kershaw
Regressions: 1566818
Regressions: 1566808
Regressions: 1571276
Regressions: 1572143
You need to log in before you can comment on or make changes to this bug.