If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

main right scrollbar still have focus after "save as.." dialog

RESOLVED DUPLICATE of bug 43156

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 43156
15 years ago
15 years ago

People

(Reporter: Giulio Prina Ricotti, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529
BuildID:    2002052918

If I select "Save target as.." or "Save page as.." and, while the dialog
opens, move the slider on the vertical scrollbar, when the dialog opens it seems
the scrollbar still has focus and it continue scrolling, but only if the mouse
pointer is within SaveAs dialog boundaries.After closing the dialog, the page
scrolls even if I'm not pressing the mouse left button.

Reproducible: Always
Steps to Reproduce:
1.Open whichever URL you want (works with huge pages where the save as dialog
takes time to show up)
2.In the body right-click and select "Save page as..." (or "Save target as.." if
you clicked on a link)
3.While the dialog opens click and hold on the slider of the right vertical
scrollbar
4. When the dialog is opened, release the button and try moving the mouse
pointer on the dialog.
5. Close the dialog

Actual Results:  The main body page still scrolls even if I've released the
mouse button.But only when the mouse pointer is in the dialog boundaries. This
stops if I click on the save as dialog window.


Expected Results:  The main body vertical scrollbar should loose focus. When I
close the "Save as.." dialog (or before opening it) mozilla should simulate a
left button release to let the scrollbar stop.

This seems to happen with modern and classic theme.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 43156 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.