Opening duplicates.cgi with no frequent bugs causes SQL syntax error

RESOLVED INVALID

Status

()

Bugzilla
Reporting/Charting
RESOLVED INVALID
16 years ago
6 years ago

People

(Reporter: Jussi Sirpoma, Assigned: gerv)

Tracking

Details

(Reporter)

Description

16 years ago
Opening duplicates.cgi in an installation where no bugs are within the frequent
bug threshold causes the following SQL syntax error:

Software error:

  SELECT bugs.bug_id, component, bug_severity, op_sys, target_milestone,
         short_desc, bug_status, resolution
  FROM bugs 
  LEFT JOIN cc selectVisible_cc ON 
                     bugs.bug_id = selectVisible_cc.bug_id AND 
                     selectVisible_cc.who = 1 WHERE ((bugs.groupset &
9223372036854775807) = bugs.groupset OR (bugs.reporter_accessible = 1 AND
bugs.reporter = 1) OR (bugs.cclist_accessible = 1 AND selectVisible_cc.who = 1
AND not isnull(selectVisible_cc.who)) OR (bugs.assigned_to = 1) OR
(bugs.qa_contact = 1)) AND (bug_status != 'CLOSED') 
  AND   ((bug_status = 'VERIFIED' AND resolution IN ('INVALID', 'WONTFIX')) 
         OR (bug_status != 'VERIFIED'))
  AND bugs.bug_id IN (): You have an error in your SQL syntax near ')' at line
10 at globals.pl line 276.

This bug might have been caused by the patch to bug 151281.
(Reporter)

Comment 1

16 years ago
This bug was submitted twice. The real bug is bug 155584.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.