Picture-in-Picture toggle shows up on TopLevelVideoDocument with audio only

VERIFIED FIXED in Firefox 69

Status

()

defect
P2
normal
VERIFIED FIXED
3 months ago
2 months ago

People

(Reporter: rowbot, Assigned: mconley)

Tracking

(Blocks 1 bug)

Trunk
mozilla69
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox69 verified)

Details

Attachments

(1 attachment)

I assume this is because the TopLevelVideoDocument uses the <video> element regardless of the file type.

STR:

  1. Visit https://testdrive-archive.azurewebsites.net/Performance/Chalkboard/Audio/Whoosh2.mp3
  2. Mouse over the video controls.

AR:
Picture-in-Picture toggle appears.

ER:
It should not appear on videos without actual video content.

Blocks: 1527926
Priority: -- → P2
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/233f132da9d4
Hide the Picture-in-Picture toggle for <video> elements that resolve to audio-only after loading metadata. r=JSON_voorhees
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Assignee: nobody → mconley
No longer regressions: 1560416
Flags: qe-verify+

Hi,

I tested this issue on Windows 10, Ubuntu 18.04 and Mac OS 10.14 with an old Nightly build 69.0a1 (20190530214830) and I was able to reproduce it.
I also tested it using the latest Nightly build 69.0a1 (2019-06-27) and I'm not able to reproduce the issue. Based on this I will mark the bug as Verified.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.