Mozilla Crashes when XSLT page is loaded second time

RESOLVED DUPLICATE of bug 129006

Status

()

Core
XSLT
--
critical
RESOLVED DUPLICATE of bug 129006
16 years ago
16 years ago

People

(Reporter: Nick Nassar, Assigned: peterv)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020702
Debian/1.0.0-0.woody.1
BuildID:    1.0.0

There is a somewhat large XSLT page created from an internal database.  The
first time it is loaded, it returns works perfectly.  The second time it is
loaded, Mozilla crashes.

Reproducible: Always
Steps to Reproduce:
1.Load this XSLT page
2.Load it again
3.Crash!

Actual Results:  Crashed with the stack trace given below

Expected Results:  Not crash :)

Mozilla 1.0 appears to crash in the same situation on Windows 98.

I will attatch a sample XML file that causes this crash.

Here is a stack trace from GDB(Linux):
#0  0x415c238a in nsXMLContentSink::Observe (this=0x8487408, 
    aSubject=0x86abe38, aTopic=0x42b86240 "xslt-done", someData=0x0)
    at nsXMLContentSink.cpp:418
#1  0x401d4526 in nsObserverService::NotifyObservers (this=0x8110f48, 
    aSubject=0x86abe38, aTopic=0x42b86240 "xslt-done", someData=0x0)
    at nsObserverService.cpp:211
#2  0x42b41e64 in XSLTProcessor::SignalTransformEnd (this=0x84ddc60)
    at XSLTProcessor.cpp:2528
#3  0x42b41aba in XSLTProcessor::TransformDocument (this=0x84ddc60, 
    aSourceDOM=0x8592d1c, aStyleDOM=0x8663834, aOutputDoc=0x89edf1c, 
    aObserver=0x87d9f64) at XSLTProcessor.cpp:2472
#4  0x415d8e6a in nsTransformMediator::TryToTransform (this=0x8b0fc30)
    at nsTransformMediator.cpp:111
#5  0x415d941f in nsTransformMediator::SetTransformObserver (this=0x8b0fc30, 
    aObserver=0x87d9f64) at nsTransformMediator.cpp:185
#6  0x415c2d2e in nsXMLContentSink::SetupTransformMediator (this=0x87d9f60)
    at nsXMLContentSink.cpp:523
#7  0x415c2045 in nsXMLContentSink::DidBuildModel (this=0x87d9f60, 
    aQualityLevel=0) at nsXMLContentSink.cpp:359
#8  0x40ee5e1b in nsExpatDriver::DidBuildModel (this=0x85d4f20, anErrorCode=0, 
    aNotifySink=1, aParser=0x86e3780, aSink=0x87d9f60) at nsExpatDriver.cpp:937
#9  0x40f054e0 in nsParser::DidBuildModel (this=0x86e3780, anErrorCode=0)
    at nsParser.cpp:1250
#10 0x40f064d2 in nsParser::ResumeParse (this=0x86e3780, allowIteration=1, 
    aIsFinalChunk=1, aCanInterrupt=1) at nsParser.cpp:1776
#11 0x40f08284 in nsParser::OnStopRequest (this=0x86e3780, request=0x873f850, 
    aContext=0x0, status=0) at nsParser.cpp:2411
#12 0x40799bd8 in nsDocumentOpenInfo::OnStopRequest (this=0x8844d30, 
    request=0x873f850, aCtxt=0x0, aStatus=0) at nsURILoader.cpp:255
#13 0x4095e764 in nsStreamListenerTee::OnStopRequest (this=0x854f098, 
    request=0x873f850, context=0x0, status=0) at nsStreamListenerTee.cpp:65
#14 0x409b7e89 in nsHttpChannel::OnStopRequest (this=0x873f850, 
    request=0x8792a6c, ctxt=0x0, status=0) at nsHttpChannel.cpp:2896
#15 0x4093faa6 in nsOnStopRequestEvent::HandleEvent (this=0x425153e8)
    at nsRequestObserverProxy.cpp:212
#16 0x4093e80d in nsARequestObserverEvent::HandlePLEvent (plev=0x425153e8)
    at nsRequestObserverProxy.cpp:115
#17 0x40245df4 in PL_HandleEvent (self=0x425153e8) at plevent.c:596
#18 0x40245be0 in PL_ProcessPendingEvents (self=0x8110e68) at plevent.c:526
#19 0x402480de in nsEventQueueImpl::ProcessPendingEvents (this=0x8110e40)
    at nsEventQueue.cpp:388
#20 0x40c0c373 in event_processor_callback (data=0x8110e40, source=8, 
    condition=GDK_INPUT_READ) at nsAppShell.cpp:184
#21 0x40c0bf15 in our_gdk_io_invoke (source=0x8238eb0, condition=G_IO_IN, 
    data=0x8143220) at nsAppShell.cpp:77
#22 0x405c9e10 in g_io_add_watch () from /usr/lib/libglib-1.2.so.0
#23 0x405cb4d8 in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#24 0x405cbae3 in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#25 0x405cbc7c in g_main_run () from /usr/lib/libglib-1.2.so.0
#26 0x404ec7e7 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#27 0x40c0c986 in nsAppShell::Run (this=0x816cca0) at nsAppShell.cpp:332
#28 0x40baf37a in nsAppShellService::Run (this=0x8139880)
    at nsAppShellService.cpp:450
#29 0x0805e092 in main1 (argc=1, argv=0xbffff9e4, nativeApp=0x0)
    at nsAppRunner.cpp:1457
#30 0x0805eedf in main (argc=1, argv=0xbffff9e4) at nsAppRunner.cpp:1806

Comment 1

16 years ago
xslt-done is an old pre-129006 topic.
Please update your build

*** This bug has been marked as a duplicate of 129006 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.