crash while loading this page

VERIFIED WORKSFORME

Status

()

Core
Internationalization
--
critical
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Corentin BARON, Assigned: Roy Yokoyama)

Tracking

({crash, intl})

Trunk
PowerPC
Mac OS X
crash, intl
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0) Gecko/20020529
BuildID:    2002052918

Mozilla 1.0 seems to have problems with many sites, including
http://www.omnigroup.com/applications/omniweb/. It crashes 3 to 4 times a day
while loading a web page. This bug is too big for me, i'll be using omniweb
until that bug is repaired. Sorry.

Reproducible: Always
Steps to Reproduce:
1.launch the URL http://www.omnigroup.com/applications/omniweb/
2.Mozilla should have crashed
3.

Actual Results:  Mozilla starts loading the page, then unexpectedly quits.

Expected Results:  load the page

Comment 1

16 years ago
Corentin, can you post TAlkback ID for this crash
mozilla/bin/components/talkback.exe ?
Severity: major → critical
Keywords: crash, stackwanted

Comment 2

16 years ago
wfm using build 2002070204 on Win2k (trunk). Sorry for the talkback.exe, I meant
to post this in another bug report, do you get a stack trace when crashing on
MacOSX ?
Please attach a MAC OS X crash log.
Under OS X, you can enable CrashReporter to provide this data. See
[http://developer.apple.com/qa/qa2001/qa1057.html].
(Reporter)

Comment 4

16 years ago
here is the MacOSX crash log for this bug :

Date/Time:  2002-07-06 22:54:25 +0200
OS Version: 10.1.5 (Build 5S66)
Host:       localhost

Command:    Mozilla
PID:        1006

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0xf3f6ffe9

Thread 0 Crashed:
 #0   0x7309d650 in FOReleaseNFNT
 #1   0x734e578c in FMSwapFont
 #2   0x73517078 in RespondToFontRequest
 #3   0x73503988 in GetFontInfo
 #4   0x023d8120 in nsFontMetricsMac::Init(nsFont const &, nsIAtom *, nsIDeviceContext *)
 #5   0x023fe8e8 in GetMetricsFor__11nsFontCacheFRC6nsFontP7nsIAtomRP14nsIFontMetr
 #6   0x023fd160 in GetMetricsFor__17DeviceContextImplFRC6nsFontP7nsIAtomRP14nsIFo
 #7   0x02c94a10 in 0x2c94a10
 #8   0x02ca6314 in 0x2ca6314
 #9   0x02c983ec in ReflowInlineFrame__13nsInlineFrameFP14nsIPresContextRC17nsHTML
 #10  0x02c97e9c in ReflowFrames__13nsInlineFrameFP14nsIPresContextRC17nsHTMLReflo
 #11  0x02c97bd0 in Reflow__13nsInlineFrameFP14nsIPresContextR19nsHTMLReflowMetric
 #12  0x02ca6314 in 0x2ca6314
 #13  0x02c983ec in ReflowInlineFrame__13nsInlineFrameFP14nsIPresContextRC17nsHTML
 #14  0x02c97e9c in ReflowFrames__13nsInlineFrameFP14nsIPresContextRC17nsHTMLReflo
 #15  0x02c97bd0 in Reflow__13nsInlineFrameFP14nsIPresContextR19nsHTMLReflowMetric
 #16  0x02ca6314 in 0x2ca6314
 #17  0x02c9f8c8 in ReflowInlineFrame__12nsBlockFrameFR18nsBlockReflowStateR12nsLi
 #18  0x02c9f5d8 in DoReflowInlineFrames__12nsBlockFrameFR18nsBlockReflowStateR12n
 #19  0x02c9f398 in nsBlockFrame::DoReflowInlineFramesAuto(nsBlockReflowState &)
 #20  0x02c9f118 in ReflowInlineFrames__12nsBlockFrameFR18nsBlockReflowState19nsLi
 #21  0x02c9d5a8 in ReflowLine__12nsBlockFrameFR18nsBlockReflowState19nsLineList_i
 #22  0x02c9cb74 in 0x2c9cb74
 #23  0x02c9ab7c in nsBlockFrame::Reflow(nsIPresContext *, nsHTMLReflowMetrics &)
 #24  0x02cc4108 in DoReflowBlock__20nsBlockReflowContextFR17nsHTMLReflowState14ns
 #25  0x02cc3b5c in ReflowBlock__20nsBlockReflowContextFP8nsIFrameRC6nsRectiR18nsC
 #26  0x02c9ea88 in 0x2c9ea88
 #27  0x02c9d1cc in 0x2c9d1cc
 #28  0x02c9cb74 in 0x2c9cb74
 #29  0x02c9ab7c in nsBlockFrame::Reflow(nsIPresContext *, nsHTMLReflowMetrics &)
 #30  0x02bf747c in ReflowChild__16nsContainerFrameFP8nsIFrameP14nsIPresContextR19
 #31  0x02c455ac in 0x2c455ac
 #32  0x02bf747c in ReflowChild__16nsContainerFrameFP8nsIFrameP14nsIPresContextR19
 #33  0x02c65edc in 0x2c65edc
 #34  0x02c66f70 in Reflow__15nsTableRowFrameFP14nsIPresContextR19nsHTMLReflowMetr
 #35  0x02bf747c in ReflowChild__16nsContainerFrameFP8nsIFrameP14nsIPresContextR19
 #36  0x02c68d20 in ReflowChildren__20nsTableRowGroupFrameFP14nsIPresContextR19nsH
 #37  0x02c6ac44 in Reflow__20nsTableRowGroupFrameFP14nsIPresContextR19nsHTMLReflo
 #38  0x02bf747c in ReflowChild__16nsContainerFrameFP8nsIFrameP14nsIPresContextR19
 #39  0x02c527bc in 0x2c527bc
 #40  0x02c4eac0 in 0x2c4eac0
 #41  0x02bf747c in ReflowChild__16nsContainerFrameFP8nsIFrameP14nsIPresContextR19
 #42  0x02c60e90 in OuterReflowChild__17nsTableOuterFrameFP14nsIPresContextP8nsIFr
 #43  0x02c62b14 in Reflow__17nsTableOuterFrameFP14nsIPresContextR19nsHTMLReflowMe
 #44  0x02cc4108 in DoReflowBlock__20nsBlockReflowContextFR17nsHTMLReflowState14ns
 #45  0x02cc3b5c in ReflowBlock__20nsBlockReflowContextFP8nsIFrameRC6nsRectiR18nsC
 #46  0x02c9ea88 in 0x2c9ea88
 #47  0x02c9d1cc in 0x2c9d1cc
 #48  0x02c9cb74 in 0x2c9cb74
 #49  0x02c9ab7c in nsBlockFrame::Reflow(nsIPresContext *, nsHTMLReflowMetrics &)
 #50  0x02cc4108 in DoReflowBlock__20nsBlockReflowContextFR17nsHTMLReflowState14ns
 #51  0x02cc3b5c in ReflowBlock__20nsBlockReflowContextFP8nsIFrameRC6nsRectiR18nsC
 #52  0x02c9ea88 in 0x2c9ea88
 #53  0x02c9d1cc in 0x2c9d1cc
 #54  0x02c9cb74 in 0x2c9cb74
 #55  0x02c9ab7c in nsBlockFrame::Reflow(nsIPresContext *, nsHTMLReflowMetrics &)
 #56  0x02bf747c in ReflowChild__16nsContainerFrameFP8nsIFrameP14nsIPresContextR19
 #57  0x02d9a64c in CanvasFrame::Reflow(nsIPresContext *, nsHTMLReflowMetrics &,  &)
 #58  0x02d556d8 in Reflow__19nsBoxToBlockAdaptorFR16nsBoxLayoutStateP14nsIPresCon
 #59  0x02d55118 in nsBoxToBlockAdaptor::DoLayout(nsBoxLayoutState &)
 #60  0x02d4fdac in nsBox::Layout(nsBoxLayoutState &)
 #61  0x02d8184c in 0x2d8184c
 #62  0x02d4fdac in nsBox::Layout(nsBoxLayoutState &)
 #63  0x02d58698 in LayoutChildAt__14nsContainerBoxFR16nsBoxLayoutStateP6nsIBoxRC6
 #64  0x02d4453c in nsGfxScrollFrameInner::LayoutBox(nsBoxLayoutState &, nsIBox *)
 #65  0x02d44a1c in 0x2d44a1c
 #66  0x02d445f4 in nsGfxScrollFrame::DoLayout(nsBoxLayoutState &)
 #67  0x02d4fdac in nsBox::Layout(nsBoxLayoutState &)
 #68  0x02d11060 in nsBoxFrame::Reflow(nsIPresContext *, nsHTMLReflowMetrics &,  const &)
 #69  0x02d43670 in Reflow__16nsGfxScrollFrameFP14nsIPresContextR19nsHTMLReflowMet
 #70  0x02bf747c in ReflowChild__16nsContainerFrameFP8nsIFrameP14nsIPresContextR19
 #71  0x02ce1b00 in Reflow__13ViewportFrameFP14nsIPresContextR19nsHTMLReflowMetric
 #72  0x02c6d800 in Dispatch__19nsHTMLReflowCommandFP14nsIPresContextR19nsHTMLRefl
 #73  0x02c1cb94 in ProcessReflowCommand__9PresShellFR11nsVoidArrayiR19nsHTMLReflo
 #74  0x02c1cd7c in PresShell::ProcessReflowCommands(int)
 #75  0x02c1c708 in HandlePLEvent(ReflowEvent *)
 #76  0x005efea0 in PL_HandleEvent
 #77  0x005efd0c in PL_ProcessPendingEvents
 #78  0x00595d9c in nsEventQueueImpl::ProcessPendingEvents(void)
 #79  0x0216893c in nsMacNSPREventQueueHandler::ProcessPLEventQueue(void)
 #80  0x021687e0 in nsMacNSPREventQueueHandler::RepeatAction(EventRecord const &)
 #81  0x01d65b14 in Repeater::DoRepeaters(EventRecord const &)
 #82  0x0217eb58 in nsMacMessagePump::DispatchEvent(int, EventRecord *)
 #83  0x0217e880 in nsMacMessagePump::DoMessagePump(void)
 #84  0x0217e1fc in nsAppShell::Run(void)
 #85  0x020a4acc in nsAppShellService::Run(void)
 #86  0x004c9efc in main1(int, char **, nsISupports *)
 #87  0x004ca93c in main

Thread 1:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x7017bf84 in __CFRunLoopRun
 #3   0x701b70ec in CFRunLoopRunSpecific
 #4   0x7017b8cc in CFRunLoopRunInMode
 #5   0x7061be08 in XIOAudioDeviceManager::NotificationThread(XIOAudioDeviceManager *)
 #6   0x706141c0 in CAPThread::Entry(CAPThread *)
 #7   0x7002054c in _pthread_body

Thread 2:
 #0   0x7000497c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x70554b80 in CarbonSelectThreadFunc
 #3   0x7002054c in _pthread_body

Thread 3:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x705593ec in CarbonOperationThreadFunc
 #3   0x7002054c in _pthread_body

Thread 4:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x70283e9c in TSWaitOnConditionTimedRelative
 #3   0x7027d740 in TSWaitOnSemaphoreCommon
 #4   0x702c2078 in TimerThread
 #5   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x70250aa8 in TSWaitOnCondition
 #3   0x7027d728 in TSWaitOnSemaphoreCommon
 #4   0x70243d0c in AsyncFileThread
 #5   0x7002054c in _pthread_body

Thread 6:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7055b884 in CarbonInetOperThreadFunc
 #3   0x7002054c in _pthread_body

PPC Thread State:
  srr0: 0x7309d650 srr1: 0x0200f030                vrsave: 0x00000000
   xer: 0x0000000c   lr: 0x7309d62c  ctr: 0x7309d618   mq: 0x00000000
    r0: 0x00000001   r1: 0xbfff9770   r2: 0xbfff8f00   r3: 0x00000101
    r4: 0xf3f6ffe9   r5: 0x0000000c   r6: 0x00000000   r7: 0x00000000
    r8: 0x005d005e   r9: 0x830902f0  r10: 0x00610000  r11: 0x834e1898
   r12: 0x7309d618  r13: 0x00000000  r14: 0x00000000  r15: 0x02de6c48
   r16: 0x02e592a4  r17: 0x00000000  r18: 0x00000426  r19: 0x02bdbf40
   r20: 0xbfff9c00  r21: 0xbfff9bfc  r22: 0x00723164  r23: 0x00010000
   r24: 0xbfff97f8  r25: 0x00000000  r26: 0x4c57464e  r27: 0x00000006
   r28: 0xbfff9878  r29: 0x00000101  r30: 0xf3f6ffe9  r31: 0x7309d62c

**********

Notice that the bug happened only on a G4, maybe a pb with a font. Mozilla works fine on my G3.
cc bstell, this seems to be font related..
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: stackwanted

Comment 6

16 years ago
I've only worked on X fonts never Mac fonts.
-> Int (fonts)
Assignee: Matti → yokoyama
Component: Browser-General → Internationalization
QA Contact: asa → ruixu

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 8

16 years ago
Page http://www.omnigroup.com/applications/omniweb/ load fine with me on 07-14
1.0.1 branch build / Mac OS 10.1.4.
(Assignee)

Comment 9

16 years ago
ylong: can you reproduce this with trunk build. If not, then please mark as WFM.
Thanks
Status: NEW → ASSIGNED

Comment 10

16 years ago
Not reproducible on 07-25 trunk build / Mac OS 10.1.5.

Resolved as works for me per requested.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 11

16 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.