Closed Bug 1555946 Opened 1 year ago Closed 1 year ago

HTMLMediaElement::mUnboundFromTree doesn't make much sense.

Categories

(Core :: DOM: Core & HTML, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: emilio, Assigned: cpearce)

References

Details

Attachments

(1 file)

It looks like it's trying to re-implement IsInComposedDoc(), but in a somewhat buggy way.

What is this member trying to do? Why doesn't it use IsInComposedDoc() in the relevant places instead?

Flags: needinfo?(cpearce)
Type: defect → task

This was added in bug 1239899. I'm pretty sure either IsInComposedDoc() didn't exist at the time, or none of the reviewers knew about it. I think we should be able to use IsInComposedDoc() here. Look like nothing breaks:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=d34de792495e0f9b6545a81a5df2806b0a7e5401

Flags: needinfo?(cpearce)
Assignee: nobody → cpearce

HTMLMediaElement::mUnboundFromTree was added in bug 1239899, and I'm pretty
sure its behaviour is intended to be the same as what IsInComposedDocument()
gives us, so we can just use that instead.

Pushed by cpearce@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/80e5addee06f
Remove HTMLMediaElement::mUnboundFromTree and use nsINode::IsInComposedDoc() instead. r=emilio
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Regressions: 1583052
You need to log in before you can comment on or make changes to this bug.