Closed Bug 1555959 Opened 6 months ago Closed 6 months ago

68 train: Split Geckoview publication from the Fennec one

Categories

(Release Engineering :: Release Automation: Other, defect)

defect
Not set

Tracking

(firefox67 wontfix, firefox67.0.1 wontfix, firefox68 fixed, firefox69 affected)

RESOLVED FIXED
Tracking Status
firefox67 --- wontfix
firefox67.0.1 --- wontfix
firefox68 --- fixed
firefox69 --- affected

People

(Reporter: jlorenzo, Assigned: jlorenzo)

References

Details

(Whiteboard: [geckoview:fenix:m6])

Attachments

(2 files)

Fenix will ship with Geckoview 68. The current Fennec schedule (1 release per week) doesn't go as fast as the mobile team needs. The ideal schedule would be: at will. Basically, the mobile team just wants a button where they can request a geckoview publication. It can be done thanks to a "force hook", like this one[1].

The Fennec ESR work paved the way for splitting these 2 graphs, notably with bug 1553853.

[1] https://tools.taskcluster.net/auth/roles/hook-id%3Aproject-releng%2Fnightly-geckoview%2Fmozilla-central

We may want to rename the nightly-geckoview/mozilla-central hook into ship-geckoview/mozilla-central since this hook just ships geckoview anyway, and it doesn't make much sense to have nightly-geckoview/mozilla-beta

68=affected because we want to be able to build GeckoView 68 Beta independently of Fennec.

Whiteboard: [geckoview:fenix:m6]

Comment 6 and comment 7 were one-line-fixes. I created the hook[1] which correctly triggered the ship_geckoview_beta graph[2]. I just gave the mobile_releases group[3] the ability to trigger this hook[4]. :sebastian confirmed he managed to trigger the hook.

[1] https://tools.taskcluster.net/hooks/project-releng/ship-geckoview%2Fmozilla-beta
[2] https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&revision=451c443ad93d89bc6f505824a8fbda602c328ef7&selectedJob=249667593
[3] Created in bug 1456533
[4] By giving hooks:trigger-hook:project-releng/ship-geckoview/mozilla-beta to https://tools.taskcluster.net/auth/roles/project-admin%3Amobile which is used by https://tools.taskcluster.net/auth/roles/mozilla-group%3Amobile_releases

Status: NEW → RESOLVED
Closed: 6 months ago
Depends on: 1456533
Resolution: --- → FIXED
See Also: → 1558282
Regressions: 1558282
See Also: 1558282
Blocks: 1564450

(In reply to Johan Lorenzo [:jlorenzo] from comment #8)

I just gave the mobile_releases group[3] the ability to trigger this hook[4]. :sebastian confirmed he managed to trigger the hook.

CosminC came to me on IRC because he'd like sheriffs to trigger this hook. I added the roles to [1] and apavel confirmed it works.

[1] https://tools.taskcluster.net/auth/roles/mozilla-group%3Asheriff

You need to log in before you can comment on or make changes to this bug.