Closed Bug 1556350 Opened 6 months ago Closed 5 months ago

Warning: Each child in an array or iterator should have a unique "key" prop.

Categories

(DevTools :: Netmonitor, defect, P2)

defect

Tracking

(firefox-esr60 unaffected, firefox-esr68 unaffected, firefox68 unaffected, firefox69 fixed)

RESOLVED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: Honza, Assigned: lloanalas)

Details

(Keywords: regression)

Attachments

(2 files)

I am seeing the following warning when selecting the Headers side panel in Network monitor:

Warning: Each child in an array or iterator should have a unique "key" prop.

Check the render method of HeadersPanel. See https://fb.me/react-warning-keys for more information.
in div (created by HeadersPanel)
in HeadersPanel (created by TabboxPanel)
in div (created by Panel)
in Panel (created by TabboxPanel)
in div (created by Tabs)
in div (created by Tabs)
in div (created by Tabs)
in Tabs (created by Sidebar)
in Sidebar (created by Tabbar)
in div (created by Tabbar)
in Tabbar (created by TabboxPanel)
in TabboxPanel (created by NetworkDetailsPanel)
in div (created by NetworkDetailsPanel)
in NetworkDetailsPanel
in VisibilityHandler
in Unknown (created by Connect(Component))
in Connect(Component) (created by MonitorPanel)
in div (created by SplitBox)
in div (created by SplitBox)
in SplitBox (created by MonitorPanel)
in div (created by MonitorPanel)
in MonitorPanel
in VisibilityHandler
in Unknown (created by Connect(Component))
in Connect(Component) (created by App)
in div (created by DropHarHandler)
in DropHarHandler (created by App)
in div (created by App)
in App
in VisibilityHandler
in Unknown (created by Connect(Component))
in Connect(Component)
in Provider react-dev.js:369:15

This looks like a regression
Honza

Priority: -- → P2
Attached image image.png

Attaching a screenshot

Honza

My STR:

  1. Load http://janodvarko.cz/test/websockets/
  2. Click the Connect button
  3. Select the UPGRADE request
  4. Check out the Browser Console

Honza

@Lloan: you might need ac_add_options --enable-debug-js-modules in your .mozconfig in order to see the warning.

Honza

Assignee: nobody → lloanalas
Status: NEW → ASSIGNED

@Honza

that worked - now i can see it! thanks!

Is there are any way to run mozregression for this issue with the config from Comment 4?

Flags: needinfo?(odvarko)

(In reply to Timea Babos from comment #6)

Is there are any way to run mozregression for this issue with the config from Comment 4?

mozregression is not building Firefox so I don't think you can link it to a mozconfig

See also: https://mozilla.github.io/mozregression/documentation/usage.html

But, you could use hg bisect and use artifact builds (to speed up builds)

Honza

Flags: needinfo?(odvarko)
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bed7cc8564f4
Each child in an array or iterator should have a unique key prop. r=nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
You need to log in before you can comment on or make changes to this bug.