Closed Bug 1556382 Opened 5 months ago Closed 4 months ago

"Phrase not found" not reset after the "Find in page" is dismissed

Categories

(Firefox for Android :: Theme and Visual Design, defect)

Firefox 68
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 69
Tracking Status
firefox67 --- unaffected
firefox68 --- verified
firefox69 --- verified

People

(Reporter: eliza.balazs, Assigned: ateslovan)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Environment:
Devices:

  • OnePlus 5T (Android 9);
  • Motorola Nexus 6 (Android 7.1.1);
  • Nexus 6P (Android 8.1.0);

Builds:

  • Nightly 68.0a1 (2019-06-01);
  • Beta 68.0b5;

Steps to reproduce:

  1. Launch Fennec and visit an article (i.e. wikipedia.org/wiki/Mozilla);
  2. Go to Menu -> Find in page;
  3. Search for some text that can't be found in the article;
  4. Dismiss the search and go back to Menu -> Find in page.

Expected result:
The text field and the error message are reset.

Actual result:
The error message is not reset after the "Find in page" is dismissed.

Notes:

  • Restarting Fennec solves the issue.

This was regressed by Bug 1345104 as discussed with andrei.teslovan.

Flags: needinfo?(andrei.teslovan)
Assignee: nobody → andrei.teslovan
Flags: needinfo?(andrei.teslovan)
Keywords: checkin-needed

Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/745cae0780ee
Reset error message for "Find in page" after dismiss; r=VladBaicu

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Flags: qe-verify+

Please request beta uplift when you get a chance.

Flags: needinfo?(andrei.teslovan)

We'll want to uplift this fix to Fennec 68 Beta so we can ship it in Fennec 68 ESR.

Verified as fixed on Nightly 69.0a1 (2019-06-10) Fennec build from the CI of mozilla-central with Nexus 6P (Android 8.1.0).
Due to my findings, I'll mark this issue as verified on Firefox 69. Thanks.

Flags: qe-verify+

Comment on attachment 9070221 [details]
Bug 1556382 - Reset error message for "Find in page" after dismiss; r?VladBaicu

Beta/Release Uplift Approval Request

  • User impact if declined: After a user searches for a keyword and the error message is displayed, if the find in page is dismissed, the next time it's opened, the error message is still displayed and it shouldn't.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Open Fennec.
  1. Click on the hamburger icon.
  2. Select find in page.
  3. Search for a keyword that can not be found on the page.
  4. Close the find in page.
  5. Open it again. The error message shouldn't be there anymore.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The change is not risky as we just clear the error message when find in page is dismissed.
  • String changes made/needed:
Flags: needinfo?(andrei.teslovan)
Attachment #9070221 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9070221 [details]
Bug 1556382 - Reset error message for "Find in page" after dismiss; r?VladBaicu

small fix for fennec, verified in 69, approved for 68.0b10

Attachment #9070221 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified as fixed on Beta 68.0b10, Nightly 68.0a1 (2019-06-13) with Nexus 6P (Android 8.1.0).
Due to my findings, I'll mark this issue as verified on Firefox 68. Thanks.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.