Closed Bug 1556403 Opened 5 months ago Closed 3 months ago

Theme author is not listed when reporting a theme from about:addons

Categories

(Toolkit :: Add-ons Manager, defect, P3, minor)

68 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox69 --- verified
firefox70 --- verified

People

(Reporter: vcarciu, Assigned: rpl)

References

Details

Attachments

(3 files)

Attached image reporttheme.png

Prerequisites:
Firefox preferences:
extensions.htmlaboutaddons.enabled
default: false
Set to true to enable the html about:addons (otherwise the abuseReport.enabled prefs will not be enough to enable the feature)

extensions.abuseReport.enabled
default: false
Set to true to enable the integrated abuse reporting

extensions.abuseReport.url
default: "https://addons.mozilla.org/api/v4/abuse/report/addon/")
Set to the url of the non-production API endpoint:
https://addons-dev.allizom.org/api/v4/abuse/report/addon/

Steps to reproduce:
1.Go to addons-dev.allizom.org and install a Theme
2.Go to about:addons and select Themes section
3.Try to report abuse the installed theme

Expected results:
Theme author is displayed under theme name through the report abuse flow

Actual results:
Theme author is not displayed

NOTES:
Please see attached screenshot

Assignee: nobody → lgreco
Blocks: 1540175
Status: NEW → ASSIGNED
Priority: -- → P2

I'm changing the priority to P3 as this seems to only be reproducible with themes installed from addons-dev, due to not being able to fill the metadata from the AddonRepository data (which instead works as expected when a theme is installed from addons.mozilla.org).

Severity: normal → minor
Priority: P2 → P3
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/d8ecb078c9a1
Hide abuse report author container element when addon author metadata is not available. r=mstriemer
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Verified as fixed in latest FF70.
Please see attached postfix screenshot

Status: RESOLVED → VERIFIED
Attached image postfixabuse.png

Comment on attachment 9073570 [details]
Bug 1556403 - Hide abuse report author container element when addon author metadata is not available. r?mstriemer!

Beta/Release Uplift Approval Request

  • User impact if declined: The abuse report panel may show an empty author box in the panel header when the addon author metadata is not available.

With the fix applied, the author box in the panel header will be hidden when no addon author metadata is available.

  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Same STR used to verify it on Nightly
  • List of other uplifts needed: Bug 1556757
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): small change (also restricted to the abuse report panel), covered by automated tests.
  • String changes made/needed:
Attachment #9073570 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Flags: in-testsuite+

Comment on attachment 9073570 [details]
Bug 1556403 - Hide abuse report author container element when addon author metadata is not available. r?mstriemer!

Don't show author information when the metadata doesn't exist. Approved for 69.0b6.

Attachment #9073570 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Verified as fixed in FF 69.0b6.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.