[Translate.Next] “Unsaved changes” warning not triggered after switching to Suggest/Translate mode

RESOLVED INVALID

Status

defect
P3
normal
RESOLVED INVALID
2 months ago
29 days ago

People

(Reporter: tchevalier, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

STR:

Edit a string (in either Suggest or Translate mode)
Switch to Suggest/Translate mode using the gear icon
Click on another string

Current results:

You move to the string you just clicked onto and lose all unsaved changes

Expected:

The “Unsaved changes” warning gets triggered, and you stay on the current string

Priority: -- → P3

Théo, I'm unable to reproduce this one using the following steps:

  1. I went to https://pontoon.mozilla.org/translate/sl/firefox/all-resources/?string=74127.
  2. I pressed "1", which changed the translation input to "1Firefox".
  3. I clicked the "Make Suggestions toggle".
  4. I clicked on the next string in the list.

The “Unsaved changes” warning appeared.

Could you provide alternative steps to reproduce?

Flags: needinfo?(theo)

I'm closing this bug since we're no longer able to reproduce it.

Feel free to reopen if it happens again.

Status: NEW → RESOLVED
Closed: 29 days ago
Flags: needinfo?(theo)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.