Closed Bug 1556462 Opened 1 year ago Closed 1 year ago

Cannot MsgGetMessage() if only have newsgroup and feed account, ie no defaultAccount, regressed by Bug 342632

Categories

(Thunderbird :: Account Manager, defect)

defect
Not set

Tracking

(thunderbird68 fixed, thunderbird69 fixed)

RESOLVED FIXED
Thunderbird 69.0
Tracking Status
thunderbird68 --- fixed
thunderbird69 --- fixed

People

(Reporter: alta88, Assigned: aceman)

References

(Regression)

Details

Attachments

(1 file, 1 obsolete file)

No description provided.

Non email accounts (chat, feeds, newsgroups) should function completely independently of whether there is an email account or not.

Flags: needinfo?(acelists)
Regressed by: null_default_server

I think I can see it.

Assignee: nobody → acelists
Status: NEW → ASSIGNED
Flags: needinfo?(acelists)
Attached patch 1556462.patch (obsolete) — Splinter Review

Would this work for you?

Attachment #9069423 - Flags: review?(alta88)
Comment on attachment 9069423 [details] [diff] [review]
1556462.patch

yes, thanks.
Attachment #9069423 - Flags: review?(alta88) → review+
Attached patch 1556462.patch v2Splinter Review

It seems that comment was misleading and the function could do useful stuff with the selected folders, the default account was only needed in some cases.

I forgot to check the case we may have Local Folders selected and then try to get mail for default account. So bail out there too if there is none.

And also the Seamonkey review would be useful.

Attachment #9069423 - Attachment is obsolete: true
Attachment #9069433 - Flags: review?(iann_bugzilla)
Attachment #9069433 - Flags: review?(frgrahl)
Comment on attachment 9069433 [details] [diff] [review]
1556462.patch v2

Looks good to me r=me
Attachment #9069433 - Flags: review?(iann_bugzilla) → review+

Thanks.

Keywords: checkin-needed
OS: Unspecified → All
Hardware: Unspecified → All
Version: unspecified → Trunk
Comment on attachment 9069433 [details] [diff] [review]
1556462.patch v2

[Approval Request Comment]
Regression caused by (bug #): bug 342632
User impact if declined: Fetching messages not working with a news/rss only profile.
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky):
Attachment #9069433 - Flags: review?(frgrahl) → approval-comm-beta?
Attachment #9069433 - Flags: approval-comm-beta? → approval-comm-beta+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/f48dd749bd70
make GetFolderMessages() work without a default account. r=alta88,IanN

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 69.0
You need to log in before you can comment on or make changes to this bug.