Closed Bug 1556548 Opened 5 years ago Closed 5 years ago

Cleanup RenderFrame and nsDisplayRemote a bit

Categories

(Core :: Graphics, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: rhunt, Assigned: rhunt)

Details

Attachments

(3 files)

  1. RenderFrame is poorly named. Its purpose is essentially to create/destroy layer trees for a BrowserParent. The name came from PRenderFrame, back when it was an IPDL protocol. I can't think of a great name, but we should make it a little bitter.
  2. RenderFrame is exposed to a good amount of code via BrowserParent. All uses only care about getting a LayersId. We should just make RenderFrame an implementation detail of BrowserParent.
  3. nsDisplayRemote lives in RenderFrame.cpp, which made sense when it was only created in the parent process, but now it can work with any nsFrameLoader. We should move it to nsDisplaySubdocument.cpp

Code outside of BrowserParent should just get the LayersId from a getter
and not worry about RenderFrame.

nsDisplayRemote no longer has any direct ties to RenderFrame and should
be moved to nsSubDocumentFrame.cpp where it's actually used/created.

Depends on D33562

RenderFrame is a very poor name for what this class does. LayerTreeOwner
isn't great (it's not the only thing that owns layer trees), but it's
hopefully clearer.

Depends on D33563

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task
Attachment #9069496 - Attachment description: Bug 1556548 - Rename RenderFrame to LayerTreeOwner. r?mattwoodrow → Bug 1556548 - Rename RenderFrame to RemoteLayerTreeOwner. r?mattwoodrow
Pushed by rhunt@eqrion.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/07506e0069c5
Make RenderFrame an internal detail to BrowserParent. r=mattwoodrow,farre
https://hg.mozilla.org/integration/mozilla-inbound/rev/dbb75fada79b
Move nsDisplayRemote to nsSubDocumentFrame.cpp. r=mattwoodrow
https://hg.mozilla.org/integration/mozilla-inbound/rev/26f5de904414
Rename RenderFrame to RemoteLayerTreeOwner. r=mattwoodrow
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: