Closed Bug 1556551 Opened 6 months ago Closed 5 months ago

Additional preferences for Firefox 68/ESR

Categories

(Firefox :: Enterprise Policies, task, P1)

task

Tracking

()

RESOLVED FIXED
Firefox 69
Tracking Status
firefox-esr68 --- fixed
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: mkaply, Assigned: mkaply)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

There are a few more preferences we'd like to get in the Preferences policy in Firefox 68:

dom.keyboardevent.keypress.hack.dispatch_non_printable_keys.addl
dom.keyboardevent.keypress.hack.use_legacy_keycode_and_charcode.addl

In case enterprises need to workaround our keypress changes on internal sites.

datareporting.policy.dataSubmissionPolicyBypassNotification

We've had reports of folks disabling telemetry to get rid of the second tab on startup. We should provide a way to remove the tab so they don't disable telemetry.

Priority: -- → P1

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task

Comment on attachment 9073905 [details]
Bug 1556551 - Additional enterprise preference policies.

Beta/Release Uplift Approval Request

  • User impact if declined: app.update.auto policy won't work, other policies not available.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This adds additional prefs to our list. Extremely low risk, policy only.
  • String changes made/needed:
Attachment #9073905 - Flags: approval-mozilla-beta?

Are you going to land this on central first?

Flags: needinfo?(mozilla)

I thought I had, pushed now.

Flags: needinfo?(mozilla)
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/54e370fa9431
Additional enterprise preference policies. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Comment on attachment 9073905 [details]
Bug 1556551 - Additional enterprise preference policies.

let the policy engine set some additional prefs, approved for 68 rc1

Attachment #9073905 - Flags: approval-mozilla-release+
Attachment #9073905 - Flags: approval-mozilla-esr68+
Attachment #9073905 - Flags: approval-mozilla-beta?

(In reply to Mike Kaply [:mkaply] from comment #3)

  • Is this code covered by automated tests?: Yes
  • Needs manual test from QE?: No

Marking this as qe-verify- per Mike's assessment.

Flags: qe-verify-
Duplicate of this bug: 1467603
Blocks: 1579332
You need to log in before you can comment on or make changes to this bug.