Closed Bug 1556592 Opened 5 months ago Closed 5 months ago

Failed upgrade from 66 to 67 (new profile created)

Categories

(Toolkit :: Startup and Profile System, defect, major)

67 Branch
defect
Not set
major

Tracking

()

RESOLVED INVALID

People

(Reporter: yoasif, Unassigned)

Details

Saw a weird issue on nightly where after starting a profile in safe mode, I was unable to re-launch the same profile in normal mode. Decided to investigate and found a more serious issue.

Summary: Upgrading to 67 from 66 starts a completely new profile, even when using a single profile that has never been used on another release channel.

Steps to reproduce:

  1. Delete contents of ~/.mozilla/firefox
  2. Download Firefox 66.0.5, add policies.json file to prevent accidental upgrade
  3. Launch Firefox 66
  4. Add uBlock Origin to profile to ensure I can easily see the difference between this profile and a new one.
  5. Close Firefox
  6. Download Firefox 67
  7. Launch Firefox 67

What happens:

Firefox says that it created a new profile.

Expected result:

Firefox uses the profile created in step 3 above.

Additional data:

Contents of profiles.ini in 66

[General]
StartWithLastProfile=1

[Profile0]
Name=default
IsRelative=1
Path=wvkft7on.default
Default=1

Contents of profiles.ini in 67

[Install884E138B86221973]
Default=f5dxp5it.default-release
Locked=1

[Profile1]
Name=default-release
IsRelative=1
Path=f5dxp5it.default-release

[Profile0]
Name=default
IsRelative=1
Path=wvkft7on.default
Default=1

[General]
StartWithLastProfile=1
Version=2

contents of installs.ini on 67

[884E138B86221973]
Default=f5dxp5it.default-release
Locked=1

Severity: normal → major
Blocks: 1474285
Regressed by: 1474285

Are you putting Firefoc 66 and 67 into the same place?

Flags: needinfo?(yoasif)

I put them in two separate folders because I wanted to prevent any kind of contamination between versions - Firefox on Linux doesn't have an installer, so I didn't want to keep old files in the old install while overwriting the old contents of the unzipped bzip.

Flags: needinfo?(yoasif)

Then this is doing what bug 1474285 intended.

No longer blocks: 1474285
Status: NEW → RESOLVED
Closed: 5 months ago
No longer regressed by: 1474285
Resolution: --- → INVALID

I get that this is by design, but it is really confusing. Thankfully, it probably doesn't affect too many users - but what about profile restores on a new OS install? Won't this design be confusing?

(In reply to Asif Youssuff from comment #4)

I get that this is by design, but it is really confusing. Thankfully, it probably doesn't affect too many users - but what about profile restores on a new OS install? Won't this design be confusing?

Assuming they install Firefox into the same location then it should just work. It should also work if they follow the recommended steps for backing up and restoring the profile: https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #6)

Are there still users being automatically upgraded from 32 to 64 bit?
https://www.reddit.com/r/firefox/comments/bx0y4v/firefox_updated_and_deleted_all_my_addons_and/

Possibly, but the update doesn't change the install location.

You need to log in before you can comment on or make changes to this bug.