Starting Firefox in safe mode causes Firefox to think I have launched a too-old version of Firefox on next launch

VERIFIED FIXED in Firefox 67

Status

()

defect
--
major
VERIFIED FIXED
13 days ago
3 days ago

People

(Reporter: yoasif, Assigned: mossop)

Tracking

(Blocks 1 bug, {nightly-community, regression})

Trunk
mozilla69
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox67blocking verified, firefox67.0.5-, firefox68+ verified, firefox69+ verified)

Details

Attachments

(2 attachments)

Reporter

Description

13 days ago

Steps to reproduce

  1. Delete ~/.mozilla/firefox
  2. Download build 20190603160429 (not sure it matters if it is after 67, but this is what I used). Add policies.json file to disable updates.
  3. Start Firefox
  4. Notice profile is "default-release"
  5. Create new profile using about:profiles UI, call it "whatever"
  6. Quit Firefox
  7. Start Firefox
  8. Notice profile in use is "whatever", not "default-release" This is Bug 1556603
  9. Quit Firefox
  10. start Firefox with --safe-mode, start in safe mode
  11. Quit Firefox
  12. Launch Firefox

What happens:

Error message saying "You've launched an older version of Firefox"

Expected result:

No error message, Firefox launches into a profile.

Reporter

Updated

13 days ago

[Tracking Requested - why for this release]:

Users will be blocked from using their profile if they ever use safe-mode.

Assignee: nobody → dtownsend

Ok, there are a few bugs that combine to cause this behaviour. I have fixes for all of them and while I'm sure of being able to get them into betas I'm less sure of getting them into the next release. So I'm going to attach the simplest fix here that should be perfectly safe to uplift.

Depends on: 1556829, 1556832

When safe mode runs it writes out "Safe Mode" as the compatibility version (bug
1556831). Due to bug 1556832 and bug 1556829 this makes us think that the next
run is a downgrade.

This is the simplest possible fix that should be totally safe to upload to
release.

Pascal, I figure this should be in the next dot release; marking it as a blocker.

Flags: needinfo?(pascalc)
Flags: needinfo?(pascalc)

Dave, does this bug only manifests with a policies.json file to block updates? In that case that sounds like it would affect a tiny % of our users and could be included in a future dot release but would not trigger a 67.0.2 ASAP. If you think this is a widespread problem, should we stop updating users to 67.0.1? Thanks

Flags: needinfo?(dtownsend)

(In reply to Pascal Chevrel:pascalc from comment #5)

Dave, does this bug only manifests with a policies.json file to block updates? In that case that sounds like it would affect a tiny % of our users and could be included in a future dot release but would not trigger a 67.0.2 ASAP. If you think this is a widespread problem, should we stop updating users to 67.0.1? Thanks

This bug affects anyone who uses safe mode.

Flags: needinfo?(dtownsend)

(In reply to Dave Townsend [:mossop] (he/him) from comment #6)

(In reply to Pascal Chevrel:pascalc from comment #5)

Dave, does this bug only manifests with a policies.json file to block updates? In that case that sounds like it would affect a tiny % of our users and could be included in a future dot release but would not trigger a 67.0.2 ASAP. If you think this is a widespread problem, should we stop updating users to 67.0.1? Thanks

This bug affects anyone who uses safe mode.

well, I just launched 67.0.1 in safe mode and it works for me…

[EDIT] I can reproduce the bug on linux on the second start in safe mode

(In reply to Dave Townsend [:mossop] (he/him) from comment #3)

Created attachment 9069765 [details]
Bug 1556612: Hardcode considering this an upgrade if the last build to run was run in safe mode. r=froydnj

When safe mode runs it writes out "Safe Mode" as the compatibility version (bug
1556831). Due to bug 1556832 and bug 1556829 this makes us think that the next
run is a downgrade.

This is the simplest possible fix that should be totally safe to upload to
release.

Could you request an uplift to release? Thanks

Flags: needinfo?(dtownsend)

Comment 9

11 days ago
Pushed by dtownsend@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d779cd26a8f0
Hardcode considering this an upgrade if the last build to run was run in safe mode. r=froydnj

Comment on attachment 9069765 [details]
Bug 1556612: Hardcode considering this an upgrade if the last build to run was run in safe mode. r=froydnj

Beta/Release Uplift Approval Request

  • User impact if declined: After running Firefox in safe mode the next launch of Firefox will tell their user that they have downgraded firefox and without some manual steps the user will be unable to use their profile ever again.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Automated tests cover the code changed but since there are not good full startup tests it would be worth QE verifying this quickly. The steps are:
  1. From about:support restart into safe mode.
  2. Quit and launch Firefox.

Firefox should open without displaying the downgrade dialog.

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is a minimal change targetted at the specific situation here, there is no risk of it impacting anything else.
  • String changes made/needed: None
Flags: needinfo?(dtownsend)
Attachment #9069765 - Flags: approval-mozilla-release?
Attachment #9069765 - Flags: approval-mozilla-beta?
Assignee

Updated

11 days ago
Flags: qe-verify+
See Also: → 1557125

Comment 11

11 days ago

Hi,
i've been able to reproduce the bug on Mac Os 10.13 (even on the latest nightly) on my side but not on Windows10 nor on nightly or release (67.01) using a computer with lots of profiles and also a clean one that never had firefox before.

Regards
David

Comment 12

11 days ago
bugherder
Status: NEW → RESOLVED
Closed: 11 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Comment on attachment 9069765 [details]
Bug 1556612: Hardcode considering this an upgrade if the last build to run was run in safe mode. r=froydnj

Let's get this onto m-r so we can start a build for 67.0.2 soon (though we are still going to work on verifying)

Attachment #9069765 - Flags: approval-mozilla-release? → approval-mozilla-release+
Reporter

Updated

11 days ago
See Also: → 1557117
Reporter

Updated

11 days ago
See Also: 1557117

Comment on attachment 9069765 [details]
Bug 1556612: Hardcode considering this an upgrade if the last build to run was run in safe mode. r=froydnj

approved for 68.0b8

Attachment #9069765 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Reproduced the initial issue using 67.0.1 on macOS 10.13 and Ubuntu 18.04 64bit. Verified that the issue is fixed on 67.0.2 across platforms (macOS 10.13, Ubuntu 18.04 and Windows 10 64bit).
I also did some exploratory testing around it to search for potential regressions that might have surfaced but could not find any.

QA Whiteboard: [qa-triaged]

I also verified that the issue is not visible on 68.0b8 and latest 69.0a1 across platforms.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Updated

6 days ago
Blocks: 1557125
See Also: 1557125
Duplicate of this bug: 1557921

Updated

5 days ago
Duplicate of this bug: 1557603

Updated

4 days ago
Duplicate of this bug: 1558760
You need to log in before you can comment on or make changes to this bug.