scour.com - allows only IE & windows

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: MatthiasMann, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

The page http://www.scour.com doesn't accept Mozilla as a browser. It prompts
you to download IE - including the IE download url - very bad.

Reproducible: Always
Steps to Reproduce:
1. visit the URL http://www.scour.com

Comment 1

16 years ago
They also seem to block other OS's as well..ugly...

From site:

   Well now, it looks like you are not a member of the vast majority of folks
out there using a recent version of a Windows-based OS. Right on. Unfortunately,
we don't support anything other than a selection of the latest Windows systems
right now. Trust us when we say that we want to expand, we really do. For now
though, we can only hook you up with unlimited Scour goodness via Windows
Operating Systems.


Heres the detection code:
/** 
 * BROWSER DETECTION:
 * Check to see if the user is using MS Internet Explorer 5+ and windows 98+
 * If not, takes them to an explanation
 */
function validateBrowser()
{
	reason = "valid";
	var platform = navigator.platform;
	// need to add a check for win95
	// allowed window versions are 98/ME/2000/XP
	// os
		// browser
			// version
	reason = "valid";
	if( platform != "Win32" || navigator.appVersion.indexOf("Windows") == -1 ||
navigator.appVersion.indexOf("Windows 95") != -1)
	{
		if(navigator.appVersion.toLowerCase().indexOf("mac") != -1)
		{
			reason = "macintosh";
		}
		else
		{
			// it's not Windows.
			reason = "os";
		}
	}
	else
	{		
		// it is Windows, make sure it's not NT 4 or 95
		if( navigator.appVersion.toLowerCase().indexOf("nt 4") != -1 )
		{
			// it's could be one of the NT 4's we've seen.
			if( navigator.appVersion.toLowerCase().indexOf("nt") != -1 &&
navigator.appVersion.substring(navigator.appVersion.indexOf("nt"),
navigator.appVersion.length).indexOf("5") == -1 )
			{
				reason = "os";
			}
		}
		else
		{
			// valid so far, now check browser type.
			if(navigator.appVersion.indexOf("MSIE") == -1)
			{
				// it's not an IE we've heard of.
				reason = "browser";
			}
			else
			{
				// this block makes sure it's IE 5 or greater.
				var number = navigator.appVersion.substring( navigator.appVersion.indexOf("MSIE"),
navigator.appVersion.length );
				number = number.substring( number.indexOf(".") - 1, number.indexOf(".") );
				if( parseInt(number) < 5 )
				{
					reason = "browser";
				}
			}
		}
	}
	/* 	
		-debugging...
		output = "";
		output += "navigator.appName = " + navigator.appName + "-(" +
navigator.appName.length + ")" + "\n";
		output += "navigator.appVersion = " + navigator.appVersion + "-(" +
navigator.appVersion.length + ")" + "\n";
		output += "navigator.platform = " + navigator.platform + "-(" +
navigator.platform.length + ")" + "\n";
		output += "reason = " + reason;
		alert(output);
		-end debugging.
	*/
	return reason;
}



Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: www.scour.com - allows only IE → www.scour.com - allows only IE & windows

Comment 2

16 years ago
Useragent does not correct this.
My stance:
It is a different issue for them *not even to tell you about the service*.

Comment 3

16 years ago
This is as far as I am going to go to research this bug:

Site requires download client which interfaces with Windows Media Player for
Windows. Trying to download songs on windows me/ wmp 7.1 asks me to "update my
security settings." Because it is windows media player, it would not be hard for
them (or us) to make a plugin that would allow the download client and mozilla
to cooperate.

*This is after the browser detection has been dealt with.*

Comment 4

16 years ago
In attempting to work with scour support to resolve the fact that the security
update (which has to do with digital rights management), they told me to head to
this link while they fixed the problem.

Of course, I checked it in Mozilla first.
http://drmlicense.one.microsoft.com/Indivsite/indivit2.htm

We should concentrate our efforts first on making sure digital rights management
works with Mozilla. FYI: It sort of worked in Internet explorer, with the
Liscence aquisition screen unable to load. I think scour has some major bugs,
(or staff that are incorrect). the address seemed generic. 

Updated

15 years ago
Summary: www.scour.com - allows only IE & windows → scour.com - allows only IE & windows

Comment 5

15 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us

Comment 6

14 years ago
site is dead (webserver doesn't accept any connections)
-->wfm
reopen if this site will be alive again (a search on google groups turned out,
this site is dead and won't appear again)
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.