Closed Bug 1556757 Opened 5 months ago Closed 3 months ago

The "Visit the theme's website" link is not working during report abuse flow

Categories

(Toolkit :: Add-ons Manager, defect, P2)

68 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- affected
firefox68 --- wontfix
firefox69 --- verified
firefox70 --- verified

People

(Reporter: vcarciu, Assigned: rpl)

References

Details

Attachments

(3 files)

Attached image Video

Steps to reproduce:

  1. Install a theme with a support site (ie. https://addons-dev.allizom.org/en-US/firefox/addon/victorrrrr/)
    2.From about:addons , Themes section, try to report the theme using the "Doesn't work or breaks browser display"
    3.Click the "Visit the theme's website" link from next step

Expected results:
Theme's support site should be opened

Actual results:
Nothing happens

Please see attached video for this issue.

NOTES:
Working for Extensions

Depends on: 1558540
No longer depends on: 1558540
Priority: -- → P2
Duplicate of this bug: 1558829
Assignee: nobody → lgreco
Status: NEW → ASSIGNED
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/fc6b4b3480aa
Abuse Report panel should not show the 'broken reason' suggestion when addon support url is missing. r=mstriemer
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Please nominate this for Beta & ESR68 approval when you get a chance.

Flags: needinfo?(lgreco)

Verified as fixed in latest FF70 .
Please see postfix screenshot attached.

Status: RESOLVED → VERIFIED
Attached image Postfix Screenshot

Comment on attachment 9073587 [details]
Bug 1556757 - Abuse Report panel should not show the 'broken reason' suggestion when addon support url is missing. r?mstriemer!

Beta/Release Uplift Approval Request

  • User impact if declined: The abuse report panel may be showing a link to a addon support url even if not available for the addon being reported, clicking on the link will not open any webpage.

With the fix applied, the suggestion with the support url will only be visible if an addon support url is available.

  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Same STR used to verify it on Nightly
  • List of other uplifts needed: Bug 1556403
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): small change (also restricted to the abuse report panel), covered by automated tests.
  • String changes made/needed:
Flags: needinfo?(lgreco)
Attachment #9073587 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Flags: in-testsuite+

Comment on attachment 9073587 [details]
Bug 1556757 - Abuse Report panel should not show the 'broken reason' suggestion when addon support url is missing. r?mstriemer!

Don't show the link to the theme's website when the metadata is missing. Approved for 69.0b6.

Attachment #9073587 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Verified as fixed in FF 69.0b6.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.