Header boxes are misaligned in day view and week view

RESOLVED FIXED in 7.0

Status

defect
RESOLVED FIXED
Last month
5 days ago

People

(Reporter: ssitter, Assigned: pmorris)

Tracking

(Blocks 1 bug, Regression, {regression})

Lightning 7.0
Dependency tree / graph

Details

Attachments

(4 attachments, 1 obsolete attachment)

Posted image header-boxes.png

Thunderbird 69.0a1 (20190604091847) with Lightning 7.1a1 on Windows 10.

In day view and week view the header boxes are misaligned. See screenshot.

Works fine using Thunderbird 68.0a1 (20190520104136) with Lightning 7.0a1, i.e. only Lightning 7.1 seems affected.

Regressed by: 1535725

Broken in Thunderbird 68.0b1 (20190606200316) with Lightning 7.0.

Version: Lightning 7.1 → Lightning 7.0
Duplicate of this bug: 1559522

Regressed by bug 1535725, which hunk? The last one?
https://hg.mozilla.org/comm-central/rev/12e96412b2c8
That could be backed out of beta if necessary.

So what was wrong about that?

Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(geoff)

All of https://hg.mozilla.org/releases/comm-beta/rev/a3f862000ed8fb0d4d1ce976b5a3c9f665cfbcc0 can be backed out. It'll still be broken in Daily.

Flags: needinfo?(geoff)

Needinfo? Jorg to back out.

Flags: needinfo?(jorgk)

I can back it out, bug can't it be fixed properly?

Flags: needinfo?(jorgk) → needinfo?(geoff)

I'm sure it can, but there's no need for it to be broken in beta. Are we trying to release a product here or what?

Flags: needinfo?(geoff)

Yes, but I prefer to avoid diverging branches as much as possible. We're far from releasing a product without regressions, but if this is the last regression, I will do the backout.

Flags: needinfo?(jorgk)

Before we back out, let me take a loot. The patch is small so this should be possible to just fix.

Assignee: nobody → mkmelin+mozilla
Flags: needinfo?(mkmelin+mozilla)

Take a look.

Not sure exactly what's going on here. May be several issues.
In 60, the whole view had a scrollbar but that didn't go up beside the actual header.

On trunk, the header goes all the way to the left (no empty space for the scrollbar).

Then, scrollbar de-xbl (I think) changed things, so the scrollbox scrollbar is not the firstchild.
The attached patch kind of fixes things, but since it's commenting out setting the overflows, it also mess some things up.

(In reply to Magnus Melin [:mkmelin] from comment #12)

On trunk, the header goes all the way to the left

To the right, I meant.

See Also: → 1561093

This patch fixes the alignment problem, and I was not able to reproduce bug 1561093 with this patch applied.

For some reason the <scrollbar> is not accessible from the <scrollbox>. this.scrollbox.querySelector("scrollbar") always returns null. It's odd because when inspecting the <scrollbox> in the dev tools I can see the <scrollbar> as its last child. But then if I log the <scrollbox> to the console its innerHTML property does not include the <scrollbar>.

(Perhaps the <scrollbar> is now shadow DOM? But I thought the dev tools indicated shadow DOM and I didn't see anything like that.)

So, since we can't access the size of the scrollbar directly, this patch just calculates it.

Attachment #9074281 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9074281 [details] [diff] [review]
calendar-view-header-alignment-0.patch

Review of attachment 9074281 [details] [diff] [review]:
-----------------------------------------------------------------

Thx! The days before Thursday may be 1-2px off when i look closely. Not sure why that would be.
Attachment #9074281 - Flags: review?(mkmelin+mozilla) → review+
Assignee: mkmelin+mozilla → paul
Status: NEW → ASSIGNED

Good catch on that one pixel offset. This version of the patch fixes that with a couple of CSS changes.

Attachment #9074281 - Attachment is obsolete: true
Attachment #9074311 - Flags: review?(richard.marti)

Looks OK to me now, the change to the reviewed version is only these two CSS changes:
https://bugzilla.mozilla.org/attachment.cgi?oldid=9074281&action=interdiff&newid=9074311&headers=1

I have no other patch to land, so this is going in now ;-)

Clearing NI since we can uplift this instead of doing the beta backout.

Flags: needinfo?(jorgk)
Target Milestone: --- → 7.1
Attachment #9074311 - Flags: approval-calendar-beta?(philipp)

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/9f2d18f74b15
Fix header box alignment in day and week views. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 20 days ago
Resolution: --- → FIXED
Comment on attachment 9074311 [details] [diff] [review]
calendar-view-header-alignment-1.patch

Thanks.
Attachment #9074311 - Flags: review?(richard.marti) → review+

Is the above a working beta? I am running 68 b2 and TB shows that's the latest one.

Roland

Will be fixed in beta 3.

(In reply to Jorg K (GMT+2) from comment #23)

Will be fixed in beta 3.

This is fixed in beta 3 with a new profile, but doesn't get fixed on an update from beta 2 to beta 3.

At least not in my release candidate testing on Windows 10 and Ubuntu 18.04.2 LTS.

Anything else I needed to do?

Status: RESOLVED → REOPENED
Flags: needinfo?(vseerror)
Flags: needinfo?(jorgk)
Resolution: FIXED → ---

No idea, Calendar updates are a constant pain. Most likely the add-on didn't update in the existing profile. Try removing the XPI from the profile, reset the magic distro pref and enable/disable the add-on until it finally works :-( - Took me a while.

Flags: needinfo?(jorgk)
Status: REOPENED → RESOLVED
Closed: 20 days ago18 days ago
Resolution: --- → FIXED
Duplicate of this bug: 1562371

See bug 1562352 for the non-update :-(

Attachment #9074311 - Flags: approval-calendar-beta?(philipp) → approval-calendar-beta+

(In reply to WaltS48 [:walts48] from comment #24)

(In reply to Jorg K (GMT+2) from comment #23)

Will be fixed in beta 3.

This is fixed in beta 3 with a new profile, but doesn't get fixed on an update from beta 2 to beta 3.

At least not in my release candidate testing on Windows 10 and Ubuntu 18.04.2 LTS.

I see the same thing with beta 4 on win10

Flags: needinfo?(vseerror)

(In reply to Jorg K (GMT+2) from comment #27)

See bug 1562352 for the non-update :-(
Ah, yes.

I don't quite follow the thread. I am now on beta 3 yet the calendar's columns are still not aligned with the header. Do I need to install a full version of beta 3 to get this corrected?

Roland

There are issues updating. Use TB 68 beta 4 and follow the release notes:
https://www-stage.thunderbird.net/en-US/thunderbird/68.0beta/releasenotes/ - Section "Known Issues".

How do I get to: "Set preference extensions.lastAppVersion to a value of 67.0 to force a refresh." I do not see where the "preference" is.

Roland

(In reply to nk2u@comcast.net from comment #32)

How do I get to: "Set preference extensions.lastAppVersion to a value of 67.0 to force a refresh." I do not see where the "preference" is.

Roland

Go to Edit > Preferences > Advanced > General tab
Then click on Config Editor button. Search for the value and change it.

OK, did that but now I lost my calendar tab! I can't seem to get it back. How do I get the calendar tab back?

(In reply to nk2u@comcast.net from comment #34)

OK, did that but now I lost my calendar tab! I can't seem to get it back. How do I get the calendar tab back?

Be creative :-)
Disable and re-enable the Lightning extension. It will come back.

The calendar files are still there and I tried all the menu options and don't see how to get the calendar tab back. I can't even look it it now.

OK, did it and now it works, thanks!

Sorin, I want to thank you for your help. In the process, I've learned quite a bit and am very appreciative! Exercises like this are very educational.

Thanks again!

(In reply to nk2u@comcast.net from comment #38)

Sorin, I want to thank you for your help. In the process, I've learned quite a bit and am very appreciative! Exercises like this are very educational.

Thanks again!

Happy to help. We all learn here.

You need to log in before you can comment on or make changes to this bug.