Closed Bug 1556809 Opened 4 months ago Closed 4 months ago

Bug 1533948 causes devtools failure of test browser_perf-overview-render-04.js

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

defect
Not set

Tracking

(firefox69 fixed)

RESOLVED FIXED
Firefox 69
Tracking Status
firefox69 --- fixed

People

(Reporter: enndeakin, Assigned: enndeakin)

References

Details

Attachments

(1 file)

Error is:

A promise chain failed to handle a rejection: this._iframe is undefined - stack: refresh@resource://devtools/client/shared/widgets/Graphs.js:650:5

The issue seems to be a race between the call to render and the subsequent call to _checkSelection. Both make checks to see if the graph is enabled and available, and create one if not, but don't record that state until afterwards. This leads both to try to create the graph and get confused as to whether the desired objects and state are ready or not.

I don't know this code at all, but adding a simple 'await' on the call to render(), as the other two calls to render() in the same file have seems to fix things. I did see one failure that might caused by this change (see https://treeherder.mozilla.org/testview.html?repo=try&revision=f2a10957f474b95adfd6b4467c60e46565f462fd ) but haven't been able to reproduce it.

If this fixes the issue I'd be happy to review this change.

Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d6958b63c9a6
wait for render() method to complete r=julienw
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Assignee: nobody → enndeakin
You need to log in before you can comment on or make changes to this bug.