Closed Bug 1556950 Opened 2 years ago Closed 2 years ago

Crash in [@ nsObserverService::AddObserver]

Categories

(Core :: Networking: DNS, defect)

defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1556911
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: calixte, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-28b5ea7c-8817-418a-85fe-383ce0190604.

Top 10 frames of crashing thread:

0 XUL nsObserverService::AddObserver xpcom/ds/nsObserverService.cpp:211
1 XUL mozilla::net::NetworkConnectivityService::GetSingleton netwerk/base/NetworkConnectivityService.cpp:29
2 XUL nsHostResolver::TrrLookup netwerk/dns/nsHostResolver.cpp:1245
3 XUL nsHostResolver::NameLookup netwerk/dns/nsHostResolver.cpp:1417
4 XUL nsHostResolver::ResolveHost netwerk/dns/nsHostResolver.cpp:1043
5 XUL nsDNSService::AsyncResolveInternal netwerk/dns/nsDNSService2.cpp:847
6 XUL nsDNSService::AsyncResolveNative netwerk/dns/nsDNSService2.cpp:911
7 XUL mozilla::net::nsSocketEvent::Run netwerk/base/nsSocketTransport2.cpp:91
8 XUL nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1176
9 XUL NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:486

There are 481 crashes (from 124 installations) in nightly 69 with buildid 20190604214415. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1518730.

[1] https://hg.mozilla.org/mozilla-central/rev?node=b857157a05c3

Flags: needinfo?(valentin.gosu)

Seems to be duplicate of Bug 1556911: Startup crash @ nsObserverService::AddObserver involving TRR

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(valentin.gosu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1556911
You need to log in before you can comment on or make changes to this bug.