LastVersion check is to strict and fails on upgrade of Ubuntu

RESOLVED DUPLICATE of bug 1553554

Status

()

defect
RESOLVED DUPLICATE of bug 1553554
2 months ago
2 months ago

People

(Reporter: carljohan, Unassigned)

Tracking

(Regression)

67 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

Upgrade from Ubuntu 16.04 to 18.04 with Firefox 67.0 installed.

Unfortunately, Firefox was built for 16.04 after 18.04.

Actual results:

Since the 18.04 Firefox was built a few minutes before the 16.04 version, Firefox wouldn't start because it was "older", even though both where 67.0.

Expected results:

LastVersion=67.0_20190517140819/20190517140819 is the version.

Checking anything after the _ is just wrong. If you have breaking incompatible changes within the same minor revision, something else is wrong.

Firefox should check that both versions were 67.0 and launch right up.

To work around I edited the file and put 66.0_xxx there instead so I didn't have to make a new profile.

Component: Untriaged → Startup and Profile System
OS: Unspecified → Linux
Product: Firefox → Toolkit
Regressed by: 1474285
Hardware: Unspecified → x86_64
Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1553554
You need to log in before you can comment on or make changes to this bug.