Closed Bug 1557019 Opened 3 months ago Closed 2 months ago

Intermittent Assertion failure: false (d3dcompiler DLL loading failed.), at z:/build/build/src/gfx/gl/GLLibraryEGL.cpp:430 and crash [@ mozilla::gl::GLLibraryEGL::DoEnsureInitialized(bool,nsTSubstring<char> * const)] for artifact builds on Windows 7

Categories

(Firefox Build System :: General, defect, P5, critical)

x86
Windows 7
defect

Tracking

(firefox-esr60 unaffected, firefox67 unaffected, firefox68 fixed, firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: cmanchester)

References

(Regression)

Details

(4 keywords)

Attachments

(1 file)

There is a Javascript error before, which might be related:

11:58:26 INFO - JavaScript warning: resource://gre/modules/Troubleshoot.jsm, line 513: Error: WebGL warning: getContext: Disallowing antialiased backbuffers due to blacklisting.

Here the first 20 frames from the crashing thread:

11:58:26 INFO - #49: soundtouch::SoundTouch::operator=[Z:\task_1559732685\build\application\firefox\xul.dll +0x7fe324]
11:58:26 INFO - #50: soundtouch::SoundTouch::operator=[Z:\task_1559732685\build\application\firefox\xul.dll +0x7b3dc1]
11:58:26 INFO - #51: soundtouch::SoundTouch::operator=[Z:\task_1559732685\build\application\firefox\xul.dll +0x7b3cdc]
11:58:26 INFO - #52: soundtouch::SoundTouch::operator=[Z:\task_1559732685\build\application\firefox\xul.dll +0x7b3baf]
11:58:26 INFO - #53: mozilla_dump_image[Z:\task_1559732685\build\application\firefox\xul.dll +0x36676f5]
11:58:26 INFO - #54: mozilla_dump_image[Z:\task_1559732685\build\application\firefox\xul.dll +0x36e35d9]
11:58:26 INFO - #55: workerlz4_maxCompressedSize[Z:\task_1559732685\build\application\firefox\xul.dll +0x4c0b80b]
11:58:26 INFO - #56: workerlz4_maxCompressedSize[Z:\task_1559732685\build\application\firefox\xul.dll +0x4d24997]
11:58:26 INFO - #57: workerlz4_maxCompressedSize[Z:\task_1559732685\build\application\firefox\xul.dll +0x4d25b1e]
11:58:26 INFO - #58: workerlz4_maxCompressedSize[Z:\task_1559732685\build\application\firefox\xul.dll +0x4d266c2]
11:58:26 INFO - #59: XRE_GetBootstrap[Z:\task_1559732685\build\application\firefox\xul.dll +0x4d32e91]
11:58:26 INFO - #60: Ordinal0[Z:\task_1559732685\build\application\firefox\firefox.exe +0x1497]
11:58:26 INFO - #61: Ordinal0[Z:\task_1559732685\build\application\firefox\firefox.exe +0x11d1]
11:58:26 INFO - #62: TargetNtUnmapViewOfSection[Z:\task_1559732685\build\application\firefox\firefox.exe +0x661f9]
11:58:26 INFO - #63: BaseThreadInitThunk[C:\windows\system32\kernel32.dll +0x4ef3c]
11:58:26 INFO - #64: RtlInitializeExceptionChain[C:\windows\SYSTEM32\ntdll.dll +0x63618]
11:58:26 INFO - #65: RtlInitializeExceptionChain[C:\windows\SYSTEM32\ntdll.dll +0x635eb]
11:58:26 INFO - Exiting due to channel error.
11:58:26 INFO - [GFX1-]: Receive IPC close with reason=AbnormalShutdown
11:58:26 INFO - mozcrash Copy/paste: Z:\task_1559732685\build\win32-minidump_stackwalk.exe c:\users\task_1559732685\appdata\local\temp\tmp0av3va.mozrunner\minidumps\ce598538-d92a-42ab-b40a-ab2ea2c28a14.dmp Z:\task_1559732685\build\symbols
11:58:46 INFO - mozcrash Saved minidump as Z:\task_1559732685\build\blobber_upload_dir\ce598538-d92a-42ab-b40a-ab2ea2c28a14.dmp
11:58:46 INFO - mozcrash Saved app info as Z:\task_1559732685\build\blobber_upload_dir\ce598538-d92a-42ab-b40a-ab2ea2c28a14.extra
11:58:46 ERROR - PROCESS-CRASH | testing\marionette\harness\marionette_harness\tests\unit\test_navigation.py TestBackForwardNavigation.test_non_remote_about_pages | application crashed [@ mozilla::gl::GLLibraryEGL::DoEnsureInitialized(bool,nsTSubstring<char> * const)]
11:58:46 INFO - Crash dump filename: c:\users\task_1559732685\appdata\local\temp\tmp0av3va.mozrunner\minidumps\ce598538-d92a-42ab-b40a-ab2ea2c28a14.dmp
11:58:46 INFO - Operating system: Windows NT
11:58:46 INFO - 6.1.7601 Service Pack 1
11:58:46 INFO - CPU: x86
11:58:46 INFO - GenuineIntel family 6 model 63 stepping 2
11:58:46 INFO - 8 CPUs
11:58:46 INFO - GPU: UNKNOWN
11:58:46 INFO - Crash reason: EXCEPTION_BREAKPOINT
11:58:46 INFO - Crash address: 0x57cebc57
11:58:46 INFO - Process uptime: 102 seconds
11:58:46 INFO - Thread 0 (crashed)
11:58:46 INFO - 0 xul.dll!mozilla::gl::GLLibraryEGL::DoEnsureInitialized(bool,nsTSubstring<char> * const) [GLLibraryEGL.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 430 + 0x0]
11:58:46 INFO - eip = 0x57cebc57 esp = 0x0021cd40 ebp = 0x0021d1a0 ebx = 0x00000000
11:58:46 INFO - esi = 0x0b7056b0 edi = 0x0021ce5c eax = 0x72ca06cc ecx = 0x000001ae
11:58:46 INFO - edx = 0x00000049 efl = 0x00000212
11:58:46 INFO - Found by: given as instruction pointer in context
11:58:46 INFO - 1 xul.dll!mozilla::gl::GLLibraryEGL::EnsureInitialized(bool,nsTSubstring<char> * const) [GLLibraryEGL.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 384 + 0x11]
11:58:46 INFO - eip = 0x57ce29d6 esp = 0x0021d1a8 ebp = 0x0021d1b4 ebx = 0x1c830071
11:58:46 INFO - esi = 0x0b7056b0 edi = 0x1c830000
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 2 xul.dll!mozilla::gl::GLContextProviderEGL::CreateOffscreen(mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> const &,mozilla::gl::SurfaceCaps const &,mozilla::gl::CreateContextFlags,nsTSubstring<char> * const) [GLContextProviderEGL.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 1130 + 0xc]
11:58:46 INFO - eip = 0x57ce6e8b esp = 0x0021d1bc ebp = 0x0021d200 esi = 0x0021d234
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 3 xul.dll!mozilla::WebGLContext::CreateAndInitGL(bool,std::vector<mozilla::WebGLContext::FailureReason,std::allocator<mozilla::WebGLContext::FailureReason> > * const) [WebGLContext.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 589 + 0x4a]
11:58:46 INFO - eip = 0x592f4a45 esp = 0x0021d208 ebp = 0x0021d270 ebx = 0x1c830071
11:58:46 INFO - esi = 0x0021d234 edi = 0x1c830000
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 4 xul.dll!mozilla::WebGLContext::SetDimensions(int,int) [WebGLContext.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 842 + 0x7]
11:58:46 INFO - eip = 0x592f581e esp = 0x0021d278 ebp = 0x0021d2e4 ebx = 0x1c830000
11:58:46 INFO - esi = 0x00000001 edi = 0x00000001
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 5 xul.dll!mozilla::dom::CanvasRenderingContextHelper::UpdateContext(JSContext *,JS::Handle<JS::Value>,mozilla::ErrorResult &) [CanvasRenderingContextHelper.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 216 + 0xc]
11:58:46 INFO - eip = 0x592d1c0c esp = 0x0021d2ec ebp = 0x0021d314 ebx = 0x0f1e2ab8
11:58:46 INFO - esi = 0x0f1e2ab0 edi = 0x1c830000
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 6 xul.dll!mozilla::dom::CanvasRenderingContextHelper::GetContext(JSContext *,nsTSubstring<char16_t> const &,JS::Handle<JS::Value>,mozilla::ErrorResult &) [CanvasRenderingContextHelper.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 174 + 0xc]
11:58:46 INFO - eip = 0x592d1919 esp = 0x0021d31c ebp = 0x0021d34c ebx = 0x0f1e2ab0
11:58:46 INFO - esi = 0x0021d394 edi = 0x5da76b10
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 7 xul.dll!mozilla::dom::HTMLCanvasElement::GetContext(JSContext *,nsTSubstring<char16_t> const &,JS::Handle<JS::Value>,mozilla::ErrorResult &) [HTMLCanvasElement.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 910 + 0x16]
11:58:46 INFO - eip = 0x59649fc1 esp = 0x0021d354 ebp = 0x0021d374 ebx = 0x5e289830
11:58:46 INFO - esi = 0x0021d394 edi = 0x0021d3d4
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 8 xul.dll!static bool mozilla::dom::HTMLCanvasElement_Binding::getContext(struct JSContext *, class JS::Handle<JSObject *>, class mozilla::dom::HTMLCanvasElement *, const class JSJitMethodCallArgs & const) [HTMLCanvasElementBinding.cpp: : 288 + 0x12]
11:58:46 INFO - eip = 0x5908db5a esp = 0x0021d37c ebp = 0x0021d474 ebx = 0x0021d494
11:58:46 INFO - esi = 0x0021d398 edi = 0x0f1e2ab0
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 9 xul.dll!mozilla::dom::binding_detail::GenericMethod<mozilla::dom::binding_detail::NormalThisPolicy,mozilla::dom::binding_detail::ThrowExceptions>(JSContext *,unsigned int,JS::Value *) [BindingUtils.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 3171 + 0xd]
11:58:46 INFO - eip = 0x59271acd esp = 0x0021d47c ebp = 0x0021d4d8 ebx = 0x5d9b8774
11:58:46 INFO - esi = 0x0d7642c0 edi = 0x000000da
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 10 xul.dll!CallJSNative(JSContext ,bool ()(JSContext *,unsigned int,JS::Value *),JS::CallArgs const &) [Interpreter.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 448 + 0x7]
11:58:46 INFO - eip = 0x5b98cb4a esp = 0x0021d4e0 ebp = 0x0021d51c ebx = 0x59271890
11:58:46 INFO - esi = 0x0021d770 edi = 0x0b617800
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 11 xul.dll!js::InternalCallOrConstruct(JSContext *,JS::CallArgs const &,js::MaybeConstruct) [Interpreter.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 540 + 0x8]
11:58:46 INFO - eip = 0x5b98c4c4 esp = 0x0021d524 ebp = 0x0021d56c ebx = 0x0021d770
11:58:46 INFO - esi = 0x0b617800 edi = 0x00000000
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 12 xul.dll!static bool InternalCall(struct JSContext *, const class js::AnyInvokeArgs & const) [Interpreter.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 595 + 0x9]
11:58:46 INFO - eip = 0x5b98d41e esp = 0x0021d574 ebp = 0x0021d5a8 ebx = 0x0021d580
11:58:46 INFO - esi = 0x0b617800 edi = 0x0021d770
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 13 xul.dll!static bool Interpret(struct JSContext *, class js::RunState & const) [Interpreter.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 3087 + 0x13]
11:58:46 INFO - eip = 0x5b9877ac esp = 0x0021d5b0 ebp = 0x0021d844 ebx = 0x00000000
11:58:46 INFO - esi = 0x0b862220 edi = 0x00000000
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 14 xul.dll!js::RunScript(JSContext *,js::RunState &) [Interpreter.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 425 + 0x9]
11:58:46 INFO - eip = 0x5b97caaf esp = 0x0021d84c ebp = 0x0021d870 ebx = 0x1cf69c90
11:58:46 INFO - esi = 0x0b617800 edi = 0x0021d888
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 15 xul.dll!js::InternalCallOrConstruct(JSContext *,JS::CallArgs const &,js::MaybeConstruct) [Interpreter.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 568 + 0xd]
11:58:46 INFO - eip = 0x5b98c4a5 esp = 0x0021d878 ebp = 0x0021d8bc ebx = 0x0021d94c
11:58:46 INFO - esi = 0x0b617800 edi = 0x00000000
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 16 xul.dll!static bool InternalCall(struct JSContext *, const class js::AnyInvokeArgs & const) [Interpreter.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 595 + 0x9]
11:58:46 INFO - eip = 0x5b98d41e esp = 0x0021d8c4 ebp = 0x0021d8f8 ebx = 0x00000000
11:58:46 INFO - esi = 0x0b617800 edi = 0x0021d94c
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 17 xul.dll!js::jit::DoCallFallback(JSContext *,js::jit::BaselineFrame *,js::jit::ICCall_Fallback *,unsigned int,JS::Value *,JS::MutableHandle<JS::Value>) [BaselineIC.cpp:155a7e2117e575ff6de6caa3dfe5b076cb455ae1 : 3729 + 0xd]
11:58:46 INFO - eip = 0x5c4e6b5c esp = 0x0021d900 ebp = 0x0021db28 ebx = 0x00000000
11:58:46 INFO - esi = 0x0021d938 edi = 0x00000003
11:58:46 INFO - Found by: call frame info
11:58:46 INFO - 18 xul.dll!truncf + 0xf995c8
11:58:46 INFO - eip = 0x5e37c8b0 esp = 0x0021db58 ebp = 0x0021db98 ebx = 0x0021db4c
11:58:46 INFO - esi = 0x2dbb9fa1 edi = 0x0ed14ce8
11:58:46 INFO - Found by: call frame info with scanning
11:58:46 INFO - 19 0xed14ce8
11:58:46 INFO - eip = 0x0ed14ce8 esp = 0x0021dba0 ebp = 0x0021dc5c
11:58:46 INFO - Found by: previous frame's frame pointer
11:58:46 INFO - 20 0x2ce70b64
11:58:46 INFO - eip = 0x2ce70b64 esp = 0x0021dc64 ebp = 0x0021dc98
11:58:46 INFO - Found by: previous frame's frame pointer

Severity: normal → critical
Keywords: assertion, crash

Observed during testing\marionette\harness\marionette_harness\tests\unit\test_navigation.py TestBackForwardNavigation.test_non_remote_about_pages

11:58:26 INFO - JavaScript warning: resource://gre/modules/Troubleshoot.jsm, line 513: Error: WebGL warning: getContext: Disallowing antialiased backbuffers due to blacklisting.
11:58:26 INFO - Assertion failure: false (d3dcompiler DLL loading failed.), at z:/build/build/src/gfx/gl/GLLibraryEGL.cpp:430

Looks to be a Windows 7 32bit only issue.

OS: Unspecified → Windows 7
Hardware: Unspecified → x86
Duplicate of this bug: 1557391

Maybe this is artifact build related? I pushed the patches to automation 2 days ago, and didn't see any of the crashes on integration branches.

I've been seeing this on my try pushes as well (artifact builds), only for a particular web-platform-test-reftest that is related to canvas.

https://treeherder.mozilla.org/#/jobs?repo=try&tier=1%2C2%2C3&author=mjzffr%40gmail.com&selectedJob=251451851

(In reply to Maja Frydrychowicz :maja_zf (she/her) (UTC-4) (maja@mozilla.com) from comment #8)

I've been seeing this on my try pushes as well (artifact builds), only for a particular web-platform-test-reftest that is related to canvas.

https://treeherder.mozilla.org/#/jobs?repo=try&tier=1%2C2%2C3&author=mjzffr%40gmail.com&selectedJob=251451851

Yep, definitely just artifact builds. This push is green: https://treeherder.mozilla.org/#/jobs?repo=try&tier=1%2C2%2C3&revision=afe2d3b7b7a9142b2c4c960e7eaa62578924f2cb

Chris, can you or someone else please have a look at this? Thanks.

Flags: needinfo?(cmanchester)
Summary: Intermittent Assertion failure: false (d3dcompiler DLL loading failed.), at z:/build/build/src/gfx/gl/GLLibraryEGL.cpp:430 and crash [@ mozilla::gl::GLLibraryEGL::DoEnsureInitialized(bool,nsTSubstring<char> * const)] → Intermittent Assertion failure: false (d3dcompiler DLL loading failed.), at z:/build/build/src/gfx/gl/GLLibraryEGL.cpp:430 and crash [@ mozilla::gl::GLLibraryEGL::DoEnsureInitialized(bool,nsTSubstring<char> * const)] for artifact builds on Windows 7

I think I see the issue here.

Assignee: nobody → cmanchester
Component: Canvas: WebGL → General
Flags: needinfo?(cmanchester)
Product: Core → Firefox Build System
Regressed by: 1539283
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/767a66943f71
Package the d3d compiler dll during artifact builds. r=dmajor
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Can be uplifted a=npotb since it only changes a build configuration we don't ship.

Whiteboard: [checkin-needed-beta]
You need to log in before you can comment on or make changes to this bug.