Closed Bug 1557164 Opened 4 months ago Closed 4 months ago

[mips*] xptcstubsdef.inc:1:94: error: unknown directive

Categories

(Firefox Build System :: General: Unsupported Platforms, defect)

defect
Not set

Tracking

(firefox68 fixed, firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: glandium, Assigned: glandium)

Details

Attachments

(1 file)

ERROR -  /builds/worker/workspace/build/src/xpcom/reflect/xptcall/xptcstubsdef.inc:1:94: error: unknown directive
INFO -  .if 3 < 10; .globl _ZN14nsXPTCStubBase5Stub3Ev; .type _ZN14nsXPTCStubBase5Stub3Ev,@function; .aent _ZN14nsXPTCStubBase5Stub3Ev,0; _ZN14nsXPTCStubBase5Stub3Ev:; dsubu $29,FRAMESZ; .cpsetup $25, GPOFF, _ZN14nsXPTCStubBase5Stub3Ev; li $12,3; b sharedstub;; .elseif 3 < 100; .globl _ZN14nsXPTCStubBase6Stub3Ev; .type _ZN14nsXPTCStubBase6Stub3Ev,@function; .aent _ZN14nsXPTCStubBase6Stub3Ev,0; _ZN14nsXPTCStubBase6Stub3Ev:; dsubu $29,FRAMESZ; .cpsetup $25, GPOFF, _ZN14nsXPTCStubBase6Stub3Ev; li $12,3; b sharedstub;; .elseif 3 < 1000; .globl _ZN14nsXPTCStubBase7Stub3Ev; .type _ZN14nsXPTCStubBase7Stub3Ev,@function; .aent _ZN14nsXPTCStubBase7Stub3Ev,0; _ZN14nsXPTCStubBase7Stub3Ev:; dsubu $29,FRAMESZ; .cpsetup $25, GPOFF, _ZN14nsXPTCStubBase7Stub3Ev; li $12,3; b sharedstub;; .else; .err; .endif
INFO -                                                                                               ^

This is because clang integrated assembler doesn't support the .aent directive (filed https://bugs.llvm.org/show_bug.cgi?id=42134)

Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/eca88f6069a7
Don't use integrated assembler with clang on mips*. r=froydnj

Comment on attachment 9070098 [details]
Bug 1557164 - Don't use integrated assembler with clang on mips*.

Beta/Release Uplift Approval Request

  • User impact if declined: Build failure on Debian mips, mipsel, mips64el (tier 3) when compiling with clang. Would be nice to have for downstreams on ESR68.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): NPOTB for what Mozilla ships.
  • String changes made/needed:
Attachment #9070098 - Flags: approval-mozilla-beta?

Comment on attachment 9070098 [details]
Bug 1557164 - Don't use integrated assembler with clang on mips*.

tier3 build fix, approved for 68.0b8

Attachment #9070098 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.