Closed Bug 1557245 Opened 6 months ago Closed 5 months ago

overflow text inside <foreignObject> no longer visible when "overflow:visible" is specified

Categories

(Core :: SVG, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- fixed

People

(Reporter: violet.bugreport, Assigned: violet.bugreport)

References

(Regression)

Details

(Keywords: regression)

Attachments

(4 files)

You should also see the overflowed text.

It works on Firefox 67, but not 68.

Thanks for finding the regression range. It's surprising since I can see the overflow text on Ubuntu 18.04 Firefix 67, with or without WebRender enabled.

Could you try to see what happens on Linux machine? Win10 has quite some weird problems that doesn't occur on other platforms.

Attached image image.png

I can also reproduce the issue on Firefox67.0.1 ubuntu18.04 ....

Interesting... I just downloaded Firefox 67.0.1, I can reproduce the problem as well...

So it's ok for Firefox 67.0 (Build ID 20190517140819), but not Firefox 67.0.1 (Build ID 20190529130856)

Hmm, I can also reproduce the issue on Firefox67.0(Build Id) Ubuntu18.04 as well as 67.0.1...

Name Firefox
Version 67.0
Build ID 20190516215225
Update History
Update Channel release
User Agent Mozilla/5.0 (X11; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

(In reply to violet.bugreport from comment #6)

Interesting... I just downloaded Firefox 67.0.1, I can reproduce the problem
as well...

So it's ok for Firefox 67.0 (Build ID 20190517140819), but not Firefox
67.0.1 (Build ID 20190529130856)

Yours build ID 20190517140819 for Firefox67.0 is strange for me.

Regressed by: 1458968

The priority flag is not set for this bug.
:dholbert, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(dholbert)
Flags: needinfo?(dholbert)
Priority: -- → P3
Duplicate of this bug: 1560267
Pushed by violet.bugreport@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/09b3d826af11
Support overflow:visible for foreignObject r=longsonr
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Assignee: nobody → violet.bugreport
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/17625 for changes under testing/web-platform/tests
Upstream PR merged
You need to log in before you can comment on or make changes to this bug.