Closed Bug 1557263 Opened 2 years ago Closed 2 years ago

Color Scheme: Dark not working on Fennec on Android 9

Categories

(Firefox for Android Graveyard :: General, defect, P3)

ARM
Android
defect

Tracking

(firefox69 affected)

RESOLVED WONTFIX
Tracking Status
firefox69 --- affected

People

(Reporter: ananuti, Unassigned)

References

()

Details

I've enabled Dark theme in Display settings and Night mode in Developer options.

AR: Color Scheme: Light

ER: Color Scheme: Dark

Hello, thanks for your report.
I tested your problem using the latest version of Nightly 68.0a1 (2019-06-21) and I am able to reproduce it using Samsung Galaxy S8 (Android 9) and OnePlus 5T (Android 9). This issue is reproducible also on Chrome, can you confirm that you're reproducing this problem in Chrome?

Flags: needinfo?(ananuti)
Hardware: ARM64 → ARM

I wonder why should i check with Chrome. This feature is not working as advertised. This is about Firefox for Android, no?

Yes, It's not working in Chrome android 75 because not supported in this version.
It works in Chrome android 76+

Flags: needinfo?(ananuti)

This feature works as expected in the FF Release 67.0.3 (as mentioned in the link: https://developer.mozilla.org/en-US/docs/Web/CSS/@media/prefers-color-scheme#Browser_compatibility). For some features, it is possible to not be activated on the nightly.

Uh-huh, If I understand bug 1532850 correctly. Fennec is something called machinery mishap.

Well, duh! It works as expected in Fenix.

The legacy Fennec only recieve security patch. I took the liberty of closing my own bug.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.