Closed Bug 1557304 Opened 4 months ago Closed 3 months ago

“About:welcome” cards overlapping issue with the browser resized to minimum width

Categories

(Firefox :: Messaging System, defect, P1, minor)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.1 - Jul 8 - 21
Tracking Status
firefox67 --- unaffected
firefox67.0.1 --- wontfix
firefox68 --- wontfix
firefox69 --- verified
firefox70 --- verified

People

(Reporter: Anca, Assigned: emcminn)

References

(Blocks 2 open bugs)

Details

(Keywords: github-merged)

Attachments

(3 files)

Attached image screenshot issue.png

[Affected versions]:

  • 67.0.2
  • 68.0b7
  • 69.0a1 (2019-05-06)

[Affected platforms]:

  • Windows 10 x64
  • macOS 10.14
  • Ubuntu 18.04 x64

[Steps to reproduce]:

  1. Open Firefox with a clean profile
  2. Dismiss the “Welcome to Firefox” modal
  3. Resize the window to its minimum width
  4. Observe the last “Welcome to Firefox” card

[Expected result]:

  • Cards are entirely visible.

[Actual result]:

  • The bottom of the last card is hidden behind about:newtab page

[Regression range]:

  • This issue is not a regression, introduced as part of Trailhead Desktop First Run feature implementation

[Additional Notes]:

  • Make sure trailhead.firstrun.branches is set to join-privacy in about:config before opening about:welcome page for Nightly and Beta.
Blocks: msrouter
Iteration: --- → 70.1 - Jul 8 - 21
Priority: -- → P2
Component: Activity Streams: Newtab → Messaging System
Priority: P2 → P1
Assignee: nobody → emcminn
Blocks: 1565293
Status: NEW → RESOLVED
Closed: 3 months ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

I have verified that the issue is no longer reproducible on the latest Nightly 70.0a1 (Build ID 20190713215744) on Windows 10, macOS 10.14, and Arch Linux 14.4.3.

Status: RESOLVED → VERIFIED

Is this something we should consider uplifting to Beta for Fx69?

Flags: needinfo?(emcminn)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #4)

Is this something we should consider uplifting to Beta for Fx69?

I would say yes; I think @Mardak was going to handle the uplifts for this bug and a couple others.

Flags: needinfo?(emcminn)

After reviewing the phabricator patch, you'll need to request beta uplift (set approval-mozilla-beta to "?" in the drop down on the left and fill out the form on the right) from the attachment details page: https://bugzilla.mozilla.org/attachment.cgi?id=9080188&action=edit

Flags: needinfo?(emcminn)

Comment on attachment 9080188 [details]
Bug 1557304 - “About:welcome” cards overlapping issue with the browser resized to minimum width

Beta/Release Uplift Approval Request

  • User impact if declined: Users won’t be able to read first run content on smaller screen sizes
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce: See QA steps in https://bugzilla.mozilla.org/show_bug.cgi?id=1557304
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Little to no risk; just a small CSS change that affects the smallest media size.
  • String changes made/needed:
Flags: needinfo?(emcminn)
Attachment #9080188 - Flags: approval-mozilla-beta?

Comment on attachment 9080188 [details]
Bug 1557304 - “About:welcome” cards overlapping issue with the browser resized to minimum width

Fixes overlapping about:welcome cards on some smaller screen sizes. Approved for 69.0b8.

Attachment #9080188 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I can confirm also, this issue is no longer reproducible on the Beta 69.0b8 on Windows 10, macOS 10.13 and Ubuntu 18.04.

You need to log in before you can comment on or make changes to this bug.