Open Bug 1557569 Opened 5 months ago Updated 3 months ago

Intermittent org.mozilla.geckoview.test.ScreenshotTest.capturePixelsThrowsCompositorNotReady | status -2

Categories

(GeckoView :: General, defect, P5)

Unspecified
All
defect

Tracking

(firefox69 disabled)

REOPENED
Tracking Status
firefox69 --- disabled

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, leave-open, regression, Whiteboard: [stockwell disabled])

Attachments

(2 files)

Filed by: btara [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=250491748&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/dAtjNprYRo6WTsmHvDB-Dg/runs/0/artifacts/public/logs/live_backing.log


[task 2019-06-06T23:02:48.734Z] 23:02:48 INFO - TEST-START | org.mozilla.geckoview.test.ScreenshotTest.capturePixelsThrowsCompositorNotReady
[task 2019-06-06T23:04:51.612Z] 23:04:51 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: id=AndroidJUnitRunner
[task 2019-06-06T23:04:51.612Z] 23:04:51 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: current=101
[task 2019-06-06T23:04:51.614Z] 23:04:51 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: class=org.mozilla.geckoview.test.ScreenshotTest
[task 2019-06-06T23:04:51.616Z] 23:04:51 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stream=
[task 2019-06-06T23:04:51.617Z] 23:04:51 INFO - org.mozilla.geckoview.test | Error in capturePixelsThrowsCompositorNotReady(org.mozilla.geckoview.test.ScreenshotTest):
[task 2019-06-06T23:04:51.617Z] 23:04:51 INFO - org.mozilla.geckoview.test | org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutException: Timed out after 120000ms
[task 2019-06-06T23:04:51.618Z] 23:04:51 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutRunnable.run(UiThreadUtils.java:56)
[task 2019-06-06T23:04:51.618Z] 23:04:51 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:730)
[task 2019-06-06T23:04:51.618Z] 23:04:51 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2019-06-06T23:04:51.618Z] 23:04:51 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils.loopUntilIdle(UiThreadUtils.java:154)
[task 2019-06-06T23:04:51.618Z] 23:04:51 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForInitialLoad(GeckoSessionTestRule.java:1314)
[task 2019-06-06T23:04:51.619Z] 23:04:51 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForOpenSession(GeckoSessionTestRule.java:1263)
[task 2019-06-06T23:04:51.619Z] 23:04:51 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.openSession(GeckoSessionTestRule.java:1259)
[task 2019-06-06T23:04:51.619Z] 23:04:51 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.prepareStatement(GeckoSessionTestRule.java:1241)
[task 2019-06-06T23:04:51.619Z] 23:04:51 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$3$1.run(GeckoSessionTestRule.java:1421)
[task 2019-06-06T23:04:51.620Z] 23:04:51 INFO - org.mozilla.geckoview.test | at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1719)
[task 2019-06-06T23:04:51.620Z] 23:04:51 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:730)
[task 2019-06-06T23:04:51.622Z] 23:04:51 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2019-06-06T23:04:51.623Z] 23:04:51 INFO - org.mozilla.geckoview.test | at android.os.Looper.loop(Looper.java:137)
[task 2019-06-06T23:04:51.623Z] 23:04:51 INFO - org.mozilla.geckoview.test | at android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2019-06-06T23:04:51.624Z] 23:04:51 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invokeNative(Native Method)
[task 2019-06-06T23:04:51.625Z] 23:04:51 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invoke(Method.java:525)
[task 2019-06-06T23:04:51.626Z] 23:04:51 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2019-06-06T23:04:51.626Z] 23:04:51 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2019-06-06T23:04:51.627Z] 23:04:51 INFO - org.mozilla.geckoview.test | at dalvik.system.NativeStart.main(Native Method)
[task 2019-06-06T23:04:51.627Z] 23:04:51 INFO - org.mozilla.geckoview.test |
[task 2019-06-06T23:04:51.628Z] 23:04:51 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: numtests=161
[task 2019-06-06T23:04:51.628Z] 23:04:51 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stack=org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutException: Timed out after 120000ms
[task 2019-06-06T23:04:51.629Z] 23:04:51 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutRunnable.run(UiThreadUtils.java:56)
[task 2019-06-06T23:04:51.630Z] 23:04:51 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:730)
[task 2019-06-06T23:04:51.630Z] 23:04:51 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2019-06-06T23:04:51.631Z] 23:04:51 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils.loopUntilIdle(UiThreadUtils.java:154)
[task 2019-06-06T23:04:51.632Z] 23:04:51 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForInitialLoad(GeckoSessionTestRule.java:1314)
[task 2019-06-06T23:04:51.632Z] 23:04:51 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForOpenSession(GeckoSessionTestRule.java:1263)
[task 2019-06-06T23:04:51.633Z] 23:04:51 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.openSession(GeckoSessionTestRule.java:1259)
[task 2019-06-06T23:04:51.633Z] 23:04:51 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.prepareStatement(GeckoSessionTestRule.java:1241)
[task 2019-06-06T23:04:51.634Z] 23:04:51 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$3$1.run(GeckoSessionTestRule.java:1421)
[task 2019-06-06T23:04:51.635Z] 23:04:51 INFO - org.mozilla.geckoview.test | at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1719)
[task 2019-06-06T23:04:51.635Z] 23:04:51 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:730)
[task 2019-06-06T23:04:51.635Z] 23:04:51 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2019-06-06T23:04:51.636Z] 23:04:51 INFO - org.mozilla.geckoview.test | at android.os.Looper.loop(Looper.java:137)
[task 2019-06-06T23:04:51.636Z] 23:04:51 INFO - org.mozilla.geckoview.test | at android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2019-06-06T23:04:51.637Z] 23:04:51 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invokeNative(Native Method)
[task 2019-06-06T23:04:51.638Z] 23:04:51 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invoke(Method.java:525)
[task 2019-06-06T23:04:51.639Z] 23:04:51 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2019-06-06T23:04:51.639Z] 23:04:51 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2019-06-06T23:04:51.640Z] 23:04:51 INFO - org.mozilla.geckoview.test | at dalvik.system.NativeStart.main(Native Method)
[task 2019-06-06T23:04:51.640Z] 23:04:51 INFO - org.mozilla.geckoview.test |
[task 2019-06-06T23:04:51.641Z] 23:04:51 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: test=capturePixelsThrowsCompositorNotReady
[task 2019-06-06T23:04:51.641Z] 23:04:51 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: -2
[task 2019-06-06T23:04:51.642Z] 23:04:51 WARNING - TEST-UNEXPECTED-FAIL | org.mozilla.geckoview.test.ScreenshotTest.capturePixelsThrowsCompositorNotReady | status -2
[task 2019-06-06T23:04:51.642Z] 23:04:51 INFO - TEST-INFO took 122891ms

Flags: needinfo?(gbrown)
Pushed by malexandru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/44acade85bf2
Disable ScreenshotTest.capturePixelsThrowsCompositorNotReady for frequent failures. r=gbrown
Flags: needinfo?(gbrown)
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

I'm reopening this bug because this test was disabled for intermittent failures, but the root cause has not been fixed.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Keywords: leave-open
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Target Milestone: mozilla69 → ---
You need to log in before you can comment on or make changes to this bug.