Closed Bug 1557764 Opened 3 months ago Closed 3 months ago

Linux and Mac build bustage on 2019-06-07

Categories

(Thunderbird :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 69.0

People

(Reporter: rjl, Assigned: rjl)

References

Details

Attachments

(1 file)

Error during the Linux and Mac builds on the nightly.
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=e24c0dd786996801f0a36f4787043aa2b18b30c3

[task 2019-06-07T10:05:56.428Z]   File "/builds/worker/workspace/build/src/testing/mozharness/mozharness/base/config.py", line 468, in get_cfgs_from_files
[task 2019-06-07T10:05:56.428Z]     search_path=config_paths + [DEFAULT_CONFIG_PATH]
[task 2019-06-07T10:05:56.428Z]   File "/builds/worker/workspace/build/src/testing/mozharness/mozharness/base/config.py", line 162, in parse_config_file
[task 2019-06-07T10:05:56.428Z]     raise IOError("Can't find %s in %s!" % (file_name, search_path))
[task 2019-06-07T10:05:56.428Z] IOError: Can't find builds/taskcluster_base_thunderbird.py in ['/builds/worker/workspace/build/src/comm/mozharness', '/builds/worker/workspace/build/src/testing/mozharness/configs']!

I haven't found the cause, but I know what's breaking and have a fix.
Something changed between m-c b8d6494caa5707d7f52c64d5d2f66d0254e69e88 and m-c: debc7af30b7e0ee50653706c19a10511ceefff83 that altered the run-task command that starts the Linux and Mac builds.

Before:
/builds/worker/bin/run-task --gecko-checkout /builds/worker/workspace/build/src --comm-checkout=/builds/worker/workspace/build/src/comm -- /builds/worker/workspace/build/src/taskcluster/scripts/builder/build-linux.sh

After:
/builds/worker/bin/run-task --gecko-checkout=/builds/worker/workspace/build/src --comm-checkout=/builds/worker/checkouts/gecko/comm --fetch-hgfingerprint -- /builds/worker/workspace/build/src/taskcluster/scripts/builder/build-linux.sh

The result being, c-c no longer being checked out under m-c so its config files are missing.

This changes the --comm-checkout parameter to the run-task command
to make sure c-c is checked out into a subdirectory of m-c.

This is from bug 1525373. Specifically https://hg.mozilla.org/mozilla-central/rev/447b8da8ebb3acd33a4ead9234b8821d4c65d4dd#l2.145

Mozharness was building the run-task command differently than the run_task transform.

See Also: → 1525373
Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/integration/autoland/rev/75f00ba2d124
comm-checkout should be under gecko-checkout. r=dustin
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 69.0
You need to log in before you can comment on or make changes to this bug.