Closed Bug 1557792 Opened 3 months ago Closed 3 months ago

[about:addons] incognito: "not_allowed" should be shown in the extension's detail page.

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- disabled
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: robwu, Assigned: robwu)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When an extension's manifest.json contains "incognito": "not_allowed", the details page at about:addons should not allow users to modify the preference, and should clearly show that the extension does not have access to private browsing windows.

In XUL about:addons, the text "Not Allowed in Private Windows" is shown.

In HTML about:addons, the private browsing row disappears, without any visual indication that the extension cannot run in private windows.

We should instead show "Not Allowed in Private Windows".

Flags: qe-verify-
See Also: → 1551947

For parity with the XUL about:addons page, this commit adds missing rows
to the details view:

  • Bug 1557792 - incognito not_allowed should show "Not Allowed in Private Windows"

  • Bug 1551947 - extensions with locked private browsing flag should not
    show inputs to control the flag, but "Requires Access to Private Windows"

Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/1eba4a29505b
Show missing private browsing rows in about:addons r=mixedpuppy
Duplicate of this bug: 1551947
Flags: needinfo?(rob)
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/3b5bd41c2585
Show missing private browsing rows in about:addons r=mixedpuppy,mstriemer
Flags: needinfo?(rob)
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Do we need to uplift this to 68 or can it ride the trains?

Flags: needinfo?(rob)

Comment on attachment 9072006 [details]
Bug 1557792 - Show missing private browsing rows in about:addons

Beta/Release Uplift Approval Request

  • User impact if declined: For some add-ons (mainly those with incognito: "not_allowed" in their manifest), it is not clear why the private browsing setting cannot be changed from about:addons.

Also (bug 1551947): the private browsing toggle is displayed even if it cannot be changed, for a few special add-ons such as Firefox Color.

  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): UI-only change in about:addons, fully covered by unit tests.
  • String changes made/needed: none
Flags: needinfo?(rob)
Attachment #9072006 - Flags: approval-mozilla-beta?

Comment on attachment 9072006 [details]
Bug 1557792 - Show missing private browsing rows in about:addons

fix an issue with the new about:addons, approved for 68.0b14

Attachment #9072006 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.